550 Please turn on SMTP Authentication in your mail client
Question asked by Dan B - December 5, 2017 at 3:30 PM
Unanswered
While logged into webmail, I send an email to someone and in about a minute, I get a bounce-back saying:
 
Failed Recipient: someone@gmail.com
Reason: Remote host said: 550 Please turn on SMTP Authentication in your mail client, or login to the
IMAP/POP3 server before sending your message.  mail.MYDOMAINNAME.com
[123.123.123.123]:57707 is not permitted to relay through this server without authentication.
 
I'm not using a mail client, and I am logged in. Even more funny is just yesterday I was able to email this person just fine back and forth. Why is my own mail server telling me I cannot relay, while sending an email via webmail?
 
I use a valid, trusted SSL certificate (for SSL and TLS), use DKIM, SPF, reverse DNS record.... the "SMTP Test" from mxtoolbox.com says everything is "OK" (all green checkmarks). My server is NOT an open relay.
 
....and just now, I decided to send another email to the failing recipient, and it went through almost instantly. Is this a Smartermail bug?
 
I am using SmarterMail Free 15.4
 
Thanks!

5 Replies

Reply to Thread
0
Looks like the remote site is telling you to turn on authentication.
 
Is your SPF record using ~all or -all, I would try ~all if it is not that.
 
 Verify your DNS entry for your MX record.
0
Dan B Replied
Thanks Patrick. I am currently using -all. I'll switch to ~all and see if I ever experience the oddity again. Weird that it seems to be 50/50 random....
2
Scarab Replied
Go to SETTINGS > PROTOCOLS and under the SMTP OUT section make sure that "Append X-Smartermail-Authenticated-As-Header" is toggled on (to the right). This will mean that outgoing messages will contain the message header called "x-smartermail-authenticateas" that demonstrates that the message sender was verified using SMTP Authentication (even if you are just using web-based mail). This header is checked by Anti-Spam services used by many providers, such as Google Mail, for validation.
 
Also under MANAGE click on your domain and in the SECURITY section make sure that "Require SMTP Authentication" is toggled on (to the right). 
0
Dan B Replied
Thanks Scarab, I didn't have that checked but I checked it (see attached image). I did already have "Require SMTP Authentication: Enabled" on :)
 
0
Scarab Replied
Ah, I didn't realize you were on v15 when I gave you v16 instructions. Glad you found the setting regardless. That setting in SMTP Out in the Protocol Settings is definitely the one you need to resolve your issue. Not sure if the service needs to be restarted for it to take affect or if just clicking it and saving it works. If it doesn't immediately resolve it just give the Smartermail Service a restart.

Reply to Thread