Can't save domain settings
Problem reported by Ton Trommelen - December 4, 2017 at 8:40 AM
Submitted
I logon as Administrator and on the "" page I click the domain I want to administer;
 
Now when I make a change: the "Save" button stays disabled, so I can't save the changed settings!
 
I have tried this using different browsers on different computers; same problem everywhere!
 
I'm using SmarterMail 16.3.6535

4 Replies

Reply to Thread
0
Jason Hungerford Replied
I had this same issue. It turns out (in my case at least - and you may want to check for yours as well) that in IIS there was a MIME file type block of file extension ".com" - once I disabled this block, I was able to save the domain settings. The reason this occurred had to do with the new call backs in SM 16. I hope this helps you.
0
Ton Trommelen Replied
Thanks for the tip....I suppose you added this to "MIME Types"? If so, what did you use for "MIME type"?

Thanks!
0
Jason Hungerford Replied
Actually, I just double checked what I had done before. This was on a server using IIS 7. It's not adding a MIME type -- it's under "Request Filtering" in my particular install, there was a list of file extensions that IIS should ignore and ".com" was in that list. I just removed that and it worked for me. Again, not sure if this will resolve your issue or not, but it's worth a shot. Also - you may want to make sure in that all fields in the domain settings are filled out correctly - I have had another experience where something wasn't filled in properly and it didn't give me a warning that it was wrong, but the Save button was disabled. So double check that as well.
0
Ton Trommelen Replied
It wasn't the Request Filtering but it turns out the "Hostname" was empty and this is why the save button was disabled.

It was quite obvious in hindsight but thanks for pointing out to check the other settings!

Reply to Thread