Apple Mail Error on Multipart Messages retrieved via IMAP
Problem reported by Scarab - November 21, 2017 at 5:12 PM
Resolved
We just upgraded to SmarterMail Enterprise v16.3.6526 last Wednesday during our Monthly Maintenance Window (previously on v16.3.6474) and ever since then all of our Apple users (MacOS X and iOS both) are frequently getting the following error when viewing messages in the Apple Mail client:
 
"This message cannot be displayed because of the way it is formatted. Ask the sender to send it again using a different format or email program."
 
This only happens with receiving Multipart/Alternative  messages via IMAP from Smartermail, and it happens to about 25-50% of the emails that are retrieved. Before Wednesday we'd see this happen to one customer every two or three years, but now it is happening to all of our Apple-using clients non-stop.
 
Our IMAP Protocol Settings in SmarterMail are as follows:

IMAP Banner: IMAP4rev1 SmarterMail
Command Timeout (Minutes): 30
Max Bad Commands: 8
Max Connections: 0
Enable IDLE Command: On
 
Doesn't seem to occur with any POP3 or EWS clients, or those using IMAP with email clients on any other OS (although we did have one user on Thunderbird on MacOS report the same error). Any ideas of what might be causing this or how it can be resolved?
 
(We do keep detailed IMAP logs but at a glance nothing looks amiss. If I had something further to go on I could parse them for clues. Might get a chance to install newest version Out-of-Band over Holiday weekend to see if that helps.)
 
 

3 Replies

Reply to Thread
0
Scarab Replied
I just disabled IDLE Command and crossing fingers that it helps.
0
Derek Curtis Replied
Employee Post
There was an issue with IMAP that was fixed in the release on November 17th. I couldn't see a release note for it, but I verified that it was in that release. (So we'll add a release note.) Try upgrading to that on your next maintenance cycle. 
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Scarab Replied
Unfortunately I missed the availability of 16.3.6530 and tried updating over the Holiday Weekend to 16.3.6535 instead. As it caused our Spool to stop processing entirely (throwing errors on every message from our Incoming Gateways with "500 command unrecognized" & "421 Too many bad commands, closing transmission channel" and refusing to process outgoing mail with "550 From domain must match authenticated domain") we were forced to rollback to 16.3.6522.

I'll give it another try with whatever version is available on our next Scheduled Maintenance Window on December 12th.

Reply to Thread