Admin interface date/time format
Problem reported by Damir Matešić - August 18, 2017 at 1:25 PM
Being Fixed
Hi, i want to have my local date/time format in admin interface. This is out of mind. Why i should use/understand the 10/5/16 5:57 PM format? I already had this problem in other part of the interface. 

10 Replies

Reply to Thread
0
Derek Curtis Replied
Employee Post
Thanks, Damir. I've added this to our sprint. Thinking a "Time Zone" setting per Administrator account would resolve this, just as you set the time zone for users....
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Alex Carnot Replied
Employee Post
Currently the date/time format is set by your browser language. Can you please confirm your browser language is set correctly? If so, what language are you using and what date/time format are you expecting?
Alex Carnot
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Damir Matešić Replied
Hi, the browser language is set to croatian. And like all normal web applications I want to have the dates displayed in my local computer culture. That mean 13.5.2017 17:05 or d.m.yyyy mm:hh.
0
Damir Matešić Replied
Derek, the time zone isn't a solution. I also see problems in the user interface. I will open a separate problem for that.
0
Alex Carnot Replied
Employee Post
Changing my browser language to Croatian had the requested result on the date/time formats across the interface:
What browser are you using?
Alex Carnot
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Damir Matešić Replied
Crome
0
Alex Carnot Replied
Employee Post
In my screenshot I'm using Chrome as well and I'm getting the format you specified.

How are you setting up your browser and your language? What specifically did you do? I set up my language through Chrome's settings under Advanced Settings > Languages. I added Croatian as a language and moved it to the top of the language list. At which point all my dates displayed properly on refresh.
Alex Carnot
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Damir Matešić Replied
Ok, you are correct. When i put croatian on the top of languages i see them well.
 
 
But try to schedule a new calendar item:
this is still not ok!
 
Also i think that the computer culture format could be more usable for this but i can live with the browser untill it works well in all parts.
0
Alex Carnot Replied
Employee Post
In Chrome the date/time input fields are based on your system time.
However it appears you need to enter in the date format manually. Which I did on windows by going to Control Panel > Clock, Language, Region > Change date, Time, or number formats > Additional Settings.
Unfortunately these input fields are out of our control and each browser decides what the format should be on its own. For example, Firefox uses the browser language to determine the input field format.
Alex Carnot
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Damir Matešić Replied
Sorry, on my computer I have already the desidered date time settings. All Croatian. I am a developer for 15 years and such thing I didn't heared for a long time. How is possible that outlook.com works well? Also google.com. But smartertools works random?

Reply to Thread