Mail hitting SMTP of SmarterMail, but not being transferred to Domain
Problem reported by Kevin Morgan - July 26, 2017 at 8:06 AM
I'm a bit confused here, my mail was working fine and then I enabled Message Sniffer and modified a few of the Antispam settings. After this, and a restart, mail is no longer appearing in the domain itself. I can search in the logs and see the eml file is created, but it is just hanging in the PROC folder.
Is this something to do with the Message Sniffer? Anything I can check?

3 Replies

Reply to Thread
Rod Lasky Replied
Employee Post
Hi Kevin.  Why is the Proc folder enabled?  If it's for a 3rd party application, then it will be up to that app to move the EML's from the Proc folder back to the spool for delivery.
Rod Lasky
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
Hello Rod, 
I do not have the Proc folder enabled, I enabled it for testing the failures and disabled it again.With that said, whether enabled or disabled the files are still moving to that folder. 
Yesterday I enabled Message Sniffer, SpamAssassin Filters, and Remote SA. After receiving no mail, I disabled Remote SA just to be sure.
Screenshots taken now: Verified that Spool Proc was off, Show data in Spool\Proc folder, with email subject for validation.
(Cannot use Hyperlinks in Post, so use links above)
Is there something I'm missing, somewhere else this is configured, is this a "turn it off and on again" moment?
Kind Regards,
Some global settings require a restart of the SmarterMail Service and I believe that "Enable Proc Folder" is one of those even though you toggled it back "Off" the SM Service is still using the last loaded setting which is still "On". If you currently have "Enable Proc Folder" turned "Off" then restarting the SM Service should be all that is needed to fix the SMTP to Delivery problem.
Note: Unless you have a third-party program like Declude that does this for automatically for you then any messages currently in the Proc Folder will have to be manually moved back to the Spool Folder after restarting the SM Service.

Reply to Thread