unable to access SmarterMail outside of the server it was installed.
Problem reported by Jessica Smith - July 9, 2017 at 5:59 PM
Submitted
Hello am Jessica,
please , i successfully installed SmarterMail 16.x on my Windows 2012 R2. (RDP)
but I can't seem to access Smartermail outside of the server where it was installed.  i carefully followed the installation procedures. Am stuck here for 3days now.
and i can't get it to work on smtp.
please, i really need an urgent help.

10 Replies

Reply to Thread
0
Richard Frank Replied
what warnings/errors etc do you see?
0
Jessica Smith Replied
Thanks for your reply
Here's the error on the browsers.
The connection has timed out
The server at 172.31.5.xxx is taking too long to respond.
The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer’s network connection.
0
Richard Frank Replied
I can only give some general advise.
I assume you use IIS. What version?
you've checked that private IP number is the number of the server
that the site responds to that IP (when you're not using a hostname)
is it the only site on the server?
Have you looked into the iis log file of the site?
all necessary asp.net versions installed?
can you create a test html file in the root folder and access that file directly like http://172.31.5.xxx/test.html?

0
Jessica Smith Replied
Thanks Richard.
Yes, am using IIS version 8
all necessary asp and tools are installed.
Am getting a HTTP Error 404 when i try to access the test html file.
yeah. only site on the server
0
Paul Blank Replied
You want to disable the Windows firewall on the server completely, at least for testing. And if you're using the server strictly for SmarterMail, you really don't want ANY anti-virus running on the server, except for an anti-virus for SmarterMail messages and attachments. The server itself is quite unlikely to get infected with anything if nothing else is going on besides SM. If the server is being used for other things, you want to make sure your anti-virus excludes SM folders and protocols. Best to uninstall it while testing SM, if you still have problems accessing SM from outside the SM server.
0
Paul Blank Replied
And make sure your Bindings are set in SM for whatever IP addresses you're using.
 
0
Jessica,
Do you have a firewall in front of the smartermail server ?
If so the proper ports have to be open.
 
Are you using any other control panels with Smartermail ?  are you possibly using Plesk ?
 
Every time i set up a new domain on our server, One of those two sets the binding access of smartermail as"webmail.domain.com"
Where I was expecting it to set as "mail.domain.com" instead (our old server used to set that)
It took me 3 days to realize that our new server server was setting it as "webmail."

www.HawaiianHope.org - Providing technology services to non profit organizations, homeless shelters, clean and sober houses and prisoner reentry programs. in 2018, in just one year, we gave away 1,000 Free Computers !

0
philip Replied
hi guys,
i got the same error when access the webmail from outside(internet)..internal no issue..
from outside is show IIS webpage..when i got to webmail.<domain>.com/Login.aspx it show 404 error..
what could be the problem? iis binding? firewall?
if firewall what port should i open? if iis binding could you share any link for me to do that?
Thank you.
0
Paul Blank Replied
As I recall, you may have issues accessing the server on port 80 (but I'm not sure). Try creating a binding for * (anything) on port 85, for example. In any event, you need to disable the Windows firewall or open the proper ports on the firewall. Start by completely disabling the firewall and trying that. Then, if you still want the firewall in-place, re-enable the firewall and open the ports you need.

And first try "outside" access from another device on the local LAN. Only if that works should you proceed to trying it in the outside world, and then you'll probably need to open ports on your Internet router, certainly so if your server is behind a NAT router.
0
Kyle Kerst Replied
Employee Post
These issues definitely sound related to firewall configurations, IP bindings, or something on the server preventing it listening on port 80 for web access. Please be sure to reenable your firewall with the appropriate settings after testing, we definitely don't want any un-firewalled servers out there!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread