[BUG] SM16 Mailing List Unsubscribe Link Has Correct URL but Wrong Text
Problem reported by Shaun Peet - June 5, 2017 at 8:35 AM
Resolved
Minor bug, since the functionality does work.  But the #UnsubscribeLink# varaible in a mailing list has the wrong text displayed in the email, however upon clicking the link it goes to the correct URL.  The fact that the text URL and the actual URL are different would (hopefully) cause people to question its legitimacy.
 
Text Of Link: http://mail.mbsportsweb.ca/public/list.aspx?action=unsubscribe&email=shaunpeet@mbsportsweb.ca&domain=test&list=smparentcouncil.ca
 
Actual URL: https://mail.mbsportsweb.ca/interface/list-opt#/out/shaunpeet@mbsportsweb.ca/test/smparentcouncil.ca
 
Also of note is that the text of the link and the actual URL (in the email) are both referring to the HTTP version.  The redirect to HTTPS seems to be working, but it would be even better if the original URL in the email (and the text version of it) both went to the correct scheme.

4 Replies

Reply to Thread
0
This bug still exists in Version 16.0.6369 (June 9).
 
0
Will this one be included in today's release?
0
I think I've figured out a little more on this one.
 
When editing a mailing list there a property called "Friendly Unsubscribe".  When that is set, then the #UnsubscribeLink# in the message will use the correct href to unsubscribe and the text will be whatever is in that property.
 
It's when the Friendly Unsubscribe property is left blank that we see the issue - the correct href is used but the text of the link is incorrect (it uses the format from SM15 and earlier).
 
0
Alex Carnot Replied
Employee Post
This has been fixed and will be included in the next release.
Alex Carnot
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread