[BUG] SM16 Custom Login Page HTML Won't Go Away
Problem reported by Shaun Peet - May 31, 2017 at 12:45 PM
Resolved
We had some custom login page HTML on SM15, and when we upgraded to SM16 it kept it (which would be expected).  But it's no longer needed, and no matter what I do I can't seem to make it go away.
 
https://mail.mbsportsweb.ca - notice the broken image and text below the login box.
 
Here's the Login Display settings:
 
 
As a side-note there's another minor bug.  If you enable the custom login page HTML and have something in there, changing the value of the custom HTML doesn't trigger the "save" button to become enabled - so there's no way to save the changed custom HTML without changing something else on the page.
 
 
 

6 Replies

Reply to Thread
0
Matt Petty Replied
Employee Post
Thank you for reporting this, I have added it to our bug list. As a temporary solution, you can delete the companyInfo.xml file (found near mailConfig.xml for system or domainConfig.xml if domain). Instead of deleting it, you can also go into it and just edit the HTML out. Since this is an XML change remember to bounce your service.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Hi Matt,
 
I took a look at the companyInfo.xml file and this is the current content:
 
<?xml version="1.0" encoding="utf-8"?>
<CompanyInfo>
  <CustomInformation>
    <HelpText>Support Central</HelpText>
    <HelpLink>http://support.mbsportsweb.ca</HelpLink>;
    <HelpLinkEnabled>True</HelpLinkEnabled>
    <LoginText>MBSportsWeb Email Login</LoginText>
    <LoginTextEnabled>True</LoginTextEnabled>
  </CustomInformation>
  <LoginAreaConfig>
    <enabled>False</enabled>
    <LoginPageHtml />
    <logoImage />
    <loginBackgroundOption>DefaultImages</loginBackgroundOption>
    <loginBackgroundImagePath />
    <loginBackgroundColor>#332E2E</loginBackgroundColor>
  </LoginAreaConfig>
</CompanyInfo>
 
So not only is there no LoginPageHtml in the file - but what's really interesting is that there's no logoImage specified either, even though it shows in the admin area as well as on the live login page.  
 
We don't allow domains to customize the login screen.  Is there another location where this might be pulling from?
 
Shaun
0
Well this is interesting.  We us our own mail server for our own email (go figure!) and look what I found in the Smartermail/Domains/mbsportsweb.ca/companyInfo.xml file:
 
<?xml version="1.0" encoding="utf-8"?>
<CompanyInfo>
  <CustomInformation>
    <HelpText>Support Central</HelpText>
    <HelpLink>http://support.mbsportsweb.ca</HelpLink>;
    <HelpLinkEnabled>True</HelpLinkEnabled>
    <LoginText>MBSportsWeb Email Login</LoginText>
    <LoginTextEnabled>True</LoginTextEnabled>
  </CustomInformation>
  <LoginAreaConfig>
    <enabled>True</enabled>
    <LoginPageHtml>&lt;div id='companyinfo' style='max-width:280px;'&gt; 
    &lt;center&gt;
        &lt;img style='max-width:240px;max-height:140px;' src='https://mail.mbsportsweb.ca/ImagesResourceHandler.ashx?file=2147483647.png' /&gt;
        &lt;br/&gt;
        For help please go to our &lt;a href='http://support.mbsportsweb.ca' target='_blank'&gt;support page&lt;/a&gt;
    &lt;/center&gt;
&lt;/div&gt;</LoginPageHtml>
    <logoImage />
    <loginBackgroundOption>DefaultImages</loginBackgroundOption>
    <loginBackgroundImagePath />
    <loginBackgroundColor />
  </LoginAreaConfig>
</CompanyInfo>
 
So there's the custom login HTML.  However, what's really strange is that we've disabled domains to override the login page - which means that nowhere in the UI can I edit this when managing the mbsportsweb.ca domain.
 
Also interesting is that this file still does not show the logoImage - I can't seem to find where that file is specified.  I have found, however, where it is located on disk ../SmarterMail/MRS/App_Data/Images/2147483647.png.
 
I'll delete the companyInfo.xml file from the domains folder and see what happens.  But this does seem like a bug.
 
Shaun
 
0
After deleting the companyInfo.xml file from the domains folder, and reloading the domain, the main login screen no longer shows any custom HTML.  So that's good.  Still something odd going on, however.
 
Firstly, the companyInfo.xml file was re-created automatically shortly after it was deleted, with the following (I'm guessing default) contents:
 
<?xml version="1.0" encoding="utf-8"?>
<CompanyInfo>
  <CustomInformation>
    <HelpText />
    <HelpLink />
    <HelpLinkEnabled>False</HelpLinkEnabled>
    <LoginText>Login to SmarterMail</LoginText>
    <LoginTextEnabled>False</LoginTextEnabled>
  </CustomInformation>
  <LoginAreaConfig>
    <enabled>False</enabled>
    <LoginPageHtml>&lt;div id='companyinfo' style='max-width:420px;font-size:20px;'&gt;
&lt;br /&gt;
&lt;center&gt;&lt;img style='max-width:600px;max-height:140px;' src='http://smartertools.com/downloads/smartermail-logo.png' /&gt;&lt;/center&gt;
&lt;br /&gt;Hello, this is an example string of text. You can customize this text for your company.
&lt;br /&gt;&lt;br /&gt;For help please go to our &lt;a href='http://example.com\' target='_blank'&gt;support page&lt;/a&gt;
&lt;br /&gt;&lt;br /&gt;
&lt;/div&gt;</LoginPageHtml>
    <logoImage />
    <loginBackgroundOption>DefaultImages</loginBackgroundOption>
    <loginBackgroundImagePath />
    <loginBackgroundColor />
  </LoginAreaConfig>
</CompanyInfo>
 
No worries there.
 
But what is strange that when I login as the Sys Admin and go to Settings -> General Settings, just opening the page shows the "Save" button enabled.  Clicking Save then changes the button to disabled (nothing was actually changed on the page).  When I go to another page, and then back to the General Settings page, upon page load the "Save" button is enabled again.
 
Hope that helps,
 
Shaun
 
0
This bug still exists in Version 16.0.6369 (June 9).
 
Simply navigating to the Admin -> Settings -> General Settings page enables the save button even though nothing on the page has changed.
 
0
This has been fixed in Version 16.0.6376 (Jun 16, 2017).  Please mark as resolved.

Reply to Thread