Force webmail to use HTTPS - FORCE OFF
Question asked by Schalk van der Merwe - May 21, 2017 at 10:20 PM
Answered
I upgraded to V16 this weekend from V15. Upgrade was easy and everything worked well.
Browsing thru the web interface I notice the “Force webmail to use HTTPS.” Setting and without thinking twice turned it on. This immediately kicked me out of the web interface, not to allow me back again. :(
 
My question is if there is a way to turn this off via one of the .config files? My system is still running, but I am not able to get back into the portal.
 
Thanks

3 Replies

Reply to Thread
0
Derek Curtis Replied
Employee Post Marked As Answer
Hey, Schalk
 
In mailConfig.xml, look for the setting <siteWideSSLRequirement> and set it to False. That should disable the setting. As an aside, do you have a valid SSL cert set up? If so, is it configured properly?
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Hi Derek. Thanks a mill. This sorted the issue out!. To answer the last part of your answer : No, no SSL Cert was in place. As i said it was a mistake my side turning this setting on as i was not planning to run SSL on the site... Thanks for the assistance and well done with a great product.
schalk
0
Christopher Hiatt Replied
I did the same thing on one of the early betas. I seem to recall being able to log and switch it back browsing to localhost:9998 directly on the mailserver machine but not 100% positive that was all I did.

Reply to Thread