Problem with Mailing List OptInUrl resulting in 404 error page
Problem reported by George Roberts - May 15, 2017 at 7:44 PM
Being Fixed
Running 16.0.6341.  I have  a mailing list setup with users sending subscription requests to the listserv with the double opt-in option enabled.  When I send the subscription I get back a confirm email.  The URL in the optin link looks like this:
 
mail.XXXX.com/public/optin.aspx?id=NUMBER&ml=17&domain=XXXXX.com
 
When I visit that URL I end up on a 404 page.  That result URL is:
mail.XXXXX.com/Interface/errors/404.html?aspxerrorpath=/public/optin.aspx
 
The mailing list messages for that message just uses a placeholder of #OptInUrl#
 
There doesn't seem to be a public folder in 16.x?  This is an upgrade from a older SmarterMail 12.5 site.  I tried to find some way to configure this but came up empty.  Is this an upgrade issue and if so how can I fix it?  Or is it a bug?
 

3 Replies

Reply to Thread
0
Derek Curtis Replied
Employee Post
Hi, George
 
We're aware of the issue and it will be addressed in the first minor, which should be out shortly after the public release. (Within a couple of weeks.) For the time being, the temporary workaround is to simply disable double opt-in. 
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Eric Bourland Replied
I'm still having this same problem. FYI.
0
Eric Bourland Replied
Me, too. I've got some upset clients.

Reply to Thread