How can I use Domain Forward When Migrating SmarterMail from VPS to Amazon EC2
Question asked by Daniel Short - February 19, 2017 at 6:05 PM
Unanswered
I'm migrating from a VPS with SmarterMail installed to an Amazon EC2 instance with the same version of SmarterMail. My question is how to make sure that I don't lose any email when I switch over the MX records to point to the new mail server.
 
I've set the TTL values on the mail server records to be just 1 minute so that I can get a quick DNS propagation, but not everyone will honor that, so I'm trying to figure out how to use the Old server as an incoming gateway that just forwards on to the new mail server once I make the switch. However, I can't seem to get that to work.
 
Here's what I'm trying to do:
 
  1. I have two servers:
    1. server1 (current vps server)
    2. server2 (new EC2 server)
  2. I have the domain mydomain.com configured on both servers.
  3. I have SmarterMail installed on both servers, and I've copied over all of the necessary files to migrate the domains from one server to the other.
So I have mydomain.com, and the same users, set up on both servers. On server1, I've configured an incoming gateway:
  1. Options
    1. Gateway Mode: Domain Forward
    2. IP Address: server2 ip
    3. User Verification: None
    4. Enable SmarterMail Gateway Mode: False
    5. Disable Greylisting: True
  2. Domains
    1. Domain Verification: Specified Domains
    2. Specified domains: mydomain.com
I save the configuration, and I can see it in the Incoming Gateways list. I can send an email to user@mydomain.com, and it lands on server1, it does not get forwarded to server2.
 
I may be misunderstanding exactly how this works. I can't get anything to forward on to server2 at this point.
 
Thanks,
 
Dan
 
 

2 Replies

Reply to Thread
0
User Replied
Hi Dan. Since both servers are SM servers, you may need to Enable SM Gateway Mode and use the User Verification. Have you tried that?
0
I am having the exact same issue, I want to setup domain forwarding for a server migration, but it is doing nothing at all. There is nothing in the logs on either server showing any attempt to forward the mail.

My old server is SM14, new server is SM16.
I tried with and withut user auth, and with and without Smartermail gateway mode enabled.
Tried "all domains (web service)" and tried specifying domain name.

Just cannot get incoming gateway to work.
 

Reply to Thread