DMARC Issues...
Question asked by Grant Nicholas - 11/20/2016 at 3:59 PM
We've been testing SPF/DKIM and DMARC on our domains, and have a couple of questions/problems:
1) I added all the relevant DNS records to two domains, one handled by Google Apps and one handled by SmarterMail.  Messages delivered to Google are correctly passing all the SPF/DKIM and DMARC tests.  
Return messages are being received into SmarterMail and have all the correct headers, SPF, DKIM and DMARC all pass, and everything seems to work well.. UNTIL... we enabled the option 'Enable DMARC policy compliance check'. Several messages sent from the Google hosted-account were being re-added to my SmarterMail Inbox at approximately half hour intervals.  I had 5 copies of the same email after a few hours.  A look at the logs showed that the email was not being repeatedly delivered by Google, but it was just trying to filter the same message periodically.  Restarting SmarterMail didn't make any difference.  Has anyone else experienced this?
2) Does anyone know if SmarterMail send out DMARC aggregate reports to the email address specified in the DMARC DNS record?
Thanks for any assistance!

1 Reply

Reply to Thread
Grant Nicholas Replied
I've done some further testing, and checked log files, and it seems that after enabling 'Enable DMARC policy compliance check', the messages are timing out on receipt:
[2016.11.21] 14:05:18 [][58517643] cmd: DATA
[2016.11.21] 14:05:18 [][58517643] rsp: 354 Start mail input; end with <CRLF>.<CRLF>
[2016.11.21] 14:07:21 [][58517643] rsp: 421 Command timeout, closing transmission channel
[2016.11.21] 14:07:21 [][58517643] disconnected at 21/11/2016 2:07:21 PM
[2016.11.21] 14:07:27 [][58517643] rsp: 250 OK
[2016.11.21] 14:07:27 [][58517643] Data transfer succeeded, writing mail to 661855637653.eml
The sending server obviously doesn't think it's been delivered, and tries again approximately 30 minutes later.  SmarterMail on the other hand is delivering the message to my inbox.
I've changed the SMTPin Timeout from 120 to 180 seconds and will see if that makes any difference.

Reply to Thread