Use DKIM while relaying email
Question asked by Marc Ward - November 10, 2016 at 9:27 AM
Unanswered
Hello,
I am setting up a Smartermail Windows server as a relay server with DKIM signing.
 
I have a number of (trusted) linux servers that are configured to route all their outgoing email through my domains central email server.  (I was previously using MS SMTP virtual server but it doesn't support DKIM out of the box).  I configured SmarterEmail to allow relaying and have that working correctly.  However I'm having an issue getting it to add the DKIM signing.  I created a domain and setup the signing but relaying and the domain configuration appear to be separate.  
 
What can I do to get Smartermail to sign emails it relays?  (And perform spam checks).
 
Thanks,
Marc 

5 Replies

Reply to Thread
0
Von-Austin See Replied
Employee Post
Marc,
 
In order for SmarterMail to sign the message, the client must first authenticate. On your client\server that's attempting to relay are you passing valid SMTP credentials ?
 
Regarding spam checks. I would recommend checking out Bruce's guide for further recommendations. This can be found here: http://portal.chicagonettech.com/kb/a171/smartermail-antispam-settings-document.aspx
Von See
Technical Support Supervisor
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Marc Ward Replied
No, I'm trusting the IP that's sending to the relay server. As an example for what's going through, one of the servers that mail is being relayed is output from listserv software. Is there a section of the docs that talks about what I want to do?

I'll check out that link.
0
Marc Ward Replied
I set the "Allow Relay" under Protocol to "Anyone" and use the firewall to allow the IPs I want. (Though I could set Allow Relay to "Nobody" and use Security->Whitelist to allow the IP)

That link is bad atm.
0
Von-Austin See Replied
Employee Post
Marc, with SmarterMail, the message will only sign with DKIM when authenticated. This may not be supported for the scenario you are wanting to accomplish unfortunately.

Here's a direct link to the doc: https://www.chicagonettech.com/docs/pdf/Antispam%20Settings%20-%20SmarterMail.pdf
Von See
Technical Support Supervisor
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Marc Ward Replied
I configured exim4 to authenticate with Smartermail as one of the accounts in the domain. Looking at the SMTP logs I'm receiving:

Authenticated as user@domain.com

And it's sending the email on as expected. However it's not adding the DKIM signature. I made sure to remove the IP from the whitelist and SMTP bypass (Allow relay is set to Nobody). When I use the web mail interface and send an email from the account I receive it with the DKIM.

What am I missing?

Reply to Thread