skipping spam checks no local recipients
Problem reported by Michael Stopnick - October 27, 2016 at 11:47 AM
Submitted
No matter what we do we are still getting "skipping spam checks no local recipients" messages and my users are getting fed up with it. Most of my users use aliases, however I've read that by enabling scanning of outgoing message, it should scan any message going out for spam regardless of whether my users use an alias.
 
SmarterMail Version - 15.0.5976

5 Replies

Reply to Thread
0
Von-Austin See Replied
Employee Post
Michael,
 
I just tested this locally and encountered the same thing. When sending to only an alias, the spam checks appear to be skipped. I'm going to create a ticket off this post to track it internally. I'll be demonstrating this behavior to our developers tomorrow during our meeting and will update this thread with more information. 
 
 
Von See
Technical Support Supervisor
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Michael Stopnick Replied
Thank you very much.

We were told that this issue was resolved in version 12 and was the reason that we upgraded to 15. We have been getting tons of complaints still and we really need something done about this.
0
Von-Austin See Replied
Employee Post
Michael,

I demonstrated this behavior to our developers, and it turned out I had performed my test incorrect. I enabled the checks for outbound filtering, but never set a value for Outbound SMTP blocking.

Could I have you ensure that under Security -> Antispam Administration -> SMTP Blocking that outbound SMTP blocking is enabled and has a weight assigned ?

Once this is set, you should then see the outbound spam checks take hold on the alias.

You should then see entries in the logs similar to mine below:

[2016.10.28] 09:16:06 [86124] Delivery started for user@externaldomain at 9:16:06 AM
[2016.10.28] 09:16:09 [86124] Skipping spam checks: No local recipients
[2016.10.28] 09:16:12 [86124] Sending remote mail for user@externaldomain
[2016.10.28] 09:16:14 [86124] Spam check results: [_INTERNALSPAMASSASSIN: 0:0], [_COMMTOUCH: 0,Unknown]

You will still see the skipping spam checks, no local recipients as this is the message displayed due to no actual local users being specified since we are only sending to the alias, but you will see it step into spam checks for the outgoing message.

I hope this helps.
Von See
Technical Support Supervisor
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Michael Stopnick Replied
Von,

I checked and I have had everything setup as you have explained. I can see the spam checks running, however I'm still I'm getting a ton through to my users. I have all the spam filters enabled for out going mail.

I honestly don't know what to do at this point in order to lessen the spam that is getting through.

Any help would be appreciated.
0
Von-Austin See Replied
Employee Post
Michael, at this point I would recommend submitting a ticket with our support department. We can review your logs and assist you further in tracking this down. If it's a bug we will refund the ticket back to your account.
Von See
Technical Support Supervisor
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread