IMAP Retrieval also allows POP Retrieval
Problem reported by kevind - April 21, 2016 at 12:08 PM
Resolved
  1. Enable IMAP Retrieval, but not POP Retrieval for a domain
  2. Have a user go into Message Retrieval and set up a POP account
  3. Click Retrieve and it works fine.
Suggestion: consolidate the 2 checkboxes (POP & IMAP) into a single checkbox for Message Retrieval.

3 Replies

Reply to Thread
1
Andrea Rogers Replied
Employee Post
Hey Kevin,
 
Good find. I'm running 15.0.5949 and see this behavior as well. The same is true when POP Retrieval is enabled but IMAP is not -- you're still able to create an IMAP connection.
 
That being said, I may be able to offer you a work around until this is fixed. It appears that if you enable both IMAP and POP for the domain, but disable one of them for the specific user, the restriction is honored and they won't have access to the disabled option. (If you have many users that require this change, be sure to utilize the Domain and User defaults found when logged in as the System Admin)
 
Hope this helps! And thanks for the report. 

Andrea Rogers
Communications Specialist
SmarterTools Inc.
(877) 357-6278

www.smartertools.com

2
Andrea Rogers Replied
Employee Post
Hey Kevin,
 
This has been fixed in today's release:
"Fixed: Disabling POP or IMAP retrieval at the domain level now properly excludes that option when adding a message retrieval item."

Andrea Rogers
Communications Specialist
SmarterTools Inc.
(877) 357-6278

www.smartertools.com

0
kevind Replied
Confirmed that it's now working properly. Thanks!

Reply to Thread