Outbound gateway only for specific domain
Question asked by Manuel - March 18, 2016 at 1:44 AM
Answered
Hello,
I have SmarterMail Enterprise 14.5

It's possibile, only for specific domains, enabled outbound gateway (forward) all outgoing email to another mail server or another smartermail server ?
Or Outbound gateway is for all emails and all domains ?
 
Tnx
Manuel
GRAFFITI — It's Communication
Riva del Garda (TN), I-38066 – Località Pasina 46
Milano, I-20129 - via Lamberto De Bernardi 1
Verona, I-37134 - via Legnago 126
San Francisco, US-94111 California – 275 Battery St, Suite 2600
website: www.graffiti.it

21 Replies

Reply to Thread
1
Scarab Replied
Manuel,
 
Yes it is possible to set a specific (or specified) domains to use a different Outbound Gateway than all the other domains, but it isn't necessarily elegant.
 
In your SETTINGS > ROUTING > OUTGOING GATEWAYS configure your Outbound Gateway and set the "PRIORITY RANGE" to a specific range (i.e. 1 to 1). Then, in the EDIT Settings for the domain(s) you want to use this Outbound Gateway set the PRIORITY settings all to 1.

Note: Prior to setting the Priority setting for the domain(s) you want to have use this Outbound Gateway you would want to make certain that no other domains have that PRIORITY in use. You can check this in SETTINGS > DEFAULT SETTINGS > DOMAIN SETTINGS > PRIORITY (I think SmarterMail defaults begin with Priority 2). You can use DOMAIN PROPAGATION to set this for all domains. Then you can can define the Priority for the specific domain(s) to match your Outgoing Gateway setting. 
0
Manuel Replied
Tnx Scarab ;)
GRAFFITI — It's Communication
Riva del Garda (TN), I-38066 – Località Pasina 46
Milano, I-20129 - via Lamberto De Bernardi 1
Verona, I-37134 - via Legnago 126
San Francisco, US-94111 California – 275 Battery St, Suite 2600
website: www.graffiti.it
0
Api Lion Replied
Have same idea too, better smartermail give an option do select for each domain to have there own outbound gateway account to manage, this will be a very good to manage for smartermail.

please smartermail team read this post

Thank you
4
Matt Petty Replied
Employee Post Marked As Answer
Since this is not possible anymore in 16 (due to simplified priorities) we've got a new feature coming down the pipeline. Check it out!
 
There were multiple threads on and this was one of them. I tried picking the most recent.
 
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Matt Petty Replied
Employee Post
Not emoji domains :P That was a little joke.
So along with having priority settings for Gateways we are now making it so you can now have a domain send on a specific gateway.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Api Lion Replied
Hi Matt, thanks for the info for the outgoing gateway.

But could it be in latest version of 16.x? I'm currently using Version 16.0.6369.

Thanks in advance
0
Matt Petty Replied
Employee Post
It will be in the release we do today or tomorrow.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
jev.sapasap Replied
Hello,
 
When will this feature available in Smartermail v16
We are using the latest version v16.3.6474 but still, we can not assign a domain to use a specific outgoing gateway.
 
Thank you in advance.
0
John Marx Replied
When you are managing the domain you can choose under Options (first box) "Outgoing Gateway". The gateway has to be first set but we are using this for one domain to use Send Grid and it works very well. We are also on the v16.3.6474.
0
Mark Milton Replied
Under manage domain you can choose what gateway the domain uses to send emails. If you want each domain to use different just setup multiple gateways and assign each domain to the corresponding gateway.

I would like to see a feature that allows one domain to use multiple gateways such as a different gateway for each priority or an backup gateway for if the main gateway fails or after a set attempts to use the second. 

Mark Milton
Pro Tech North
Web: www.protech-north.co.uk
Email: mark.milton@protech-north.co.uk
Tel: +44 (0)1261 838282
Web Design & Web Hosting

0
jev.sapasap Replied
Hi, under manage domain, i can't see any options where I can choose what gateway the domain can use to send emails. Can you show me how and where to find it, please. Thank you
0
Hi,
To setup a Gateway http://prntscr.com/gqfdyt
To set the domain to use the gateway http://prntscr.com/gqfett

Mark Milton
Pro Tech North
Web: www.protech-north.co.uk
Email: mark.milton@protech-north.co.uk
Tel: +44 (0)1261 838282
Web Design & Web Hosting

0
jev.sapasap Replied
Hi, what version are you using? I am using SmarterMail Version - 16.3.6474
I was able to put int the Gateway.
But on the domain itself, I can not see the outgoing gateway there.
What am I missing here?

Please advice

Thank you
0
jev.sapasap Replied
Here's the screenshot
 
0
Mark Milton Replied
Hi, Am using 16.2.6442 I haven't updated in a little while. I always wait till people aren't complaining about a update before I do it.

Mark Milton
Pro Tech North
Web: www.protech-north.co.uk
Email: mark.milton@protech-north.co.uk
Tel: +44 (0)1261 838282
Web Design & Web Hosting

0
Mark Milton Replied
You look to have quite a few of the cards missing. I can have a quick look at it if you like. Send me over a email mark.milton@protech-north.co.uk. Apologies if this isn't allowed

Mark Milton
Pro Tech North
Web: www.protech-north.co.uk
Email: mark.milton@protech-north.co.uk
Tel: +44 (0)1261 838282
Web Design & Web Hosting

0
jev.sapasap Replied
Hi Matt,

I would like to check with you why I am not seeing this in the current release of smartermail. I am using version SmarterMail Professional Edition Version: 16.3.6488

Thank you
1
jev.sapasap Replied
Hello, 
 
Any update on this, please.
Thank you
0
jev.sapasap Replied
Hello,

So far no update on this?
0
Pravin Taneja Replied
This is still not functioning well. Am using version 16.x and able to define outgoing gateway from Settings => Gateways / Failover => Outgoing tab => New. Once this is defined and enabled then it applies to each and every domain.
 
If you use Manage => Select all domains => Domain Defaults then there is no option to disable outgoing gateway to change to none & propagate the changes to all domains.
 
So this setting needs to be applied for one domain at a time. Anyway, choose the specific domain that should not use an outgoing gateway.  Under Options -> Outgoing Gateway is already set to None. Change to the outgoing gateway configured, click on save, then change it back to None and click on Save. Try sending email from this domain, it uses the outgoing gateway to send the email. FAILED - you cannot disable an active Outgoing Gateway for some domains.
 
Try it from another way, go back to Settings => Gateway / Failover => Outgoing tab => Edit the outgoing gateway configured and set its Enabled to false. Then return back to the domain that is supposed to use the outgoing gateway. Go to options and under Outgoing Gateway - select the outgoing gateway. Save the details and try sending email from this account. It doesn't use the Outgoing Gateway because its not enabled. FAILED - you cannot configure SmarterMail to use Outgoing Gateway for some specific domains.
 
Am I doing something wrong? Any updates about this feature?
Regards,Pravin TanejaIntelli Softwares Pte Ltdhttps://www.IntelliSoftwares.com
0
jev.sapasap Replied
I have upgraded professional to enterprise. and the failover was activated.
So, simply saying, the feature is not available on Professional Edition.

Thank you for the help guys

Reply to Thread