Latest SmarterMail 14.x build (14.3.5752) is replacing space characters " " with underscores "_" in email titles.
Problem reported by Webio - 10/8/2015 at 1:48 AM
Resolved
Hello,
 
does someone experienced issue after upgrading to latest 14.x build (14.3.5752) where email titles empty spaces between words where replaced
with underscore characters (" " -> "_")? I've noticed it on my e-mail account
and one client reported me that 70% of his emails is being affected by this issue.
 
Thanks

23 Replies

Reply to Thread
1
Christian Schmit Replied
 
If an email subject has non-ASCII characters, (which is not allowed by the RFC) this can happen. To include non-ASCII characters in subjects, the subject is required to be properly encoded (e.g. with UTF-8). Any normal mail client will automatically handle that for you, so it's likely a bug in a custom written script that generated the invalid subject. 
 
Christian
 
 
1
Webio Replied
Actually you are right. This is related only to webmail client. In Thunderbird I can see correct title names. This doesn't change that this has happened after upgrade to latest build so IMHO this is a still bug in SM.
Message source show that subject is encoded:
 
=?UTF-8?Q?Przej=C5=9Bciowa_Kolekcja_Jesienna=C2=A0Lightweight?=
 
and it should display in webmail as:
 
Przejściowa Kolekcja Jesienna Lightweight
 
instead of 
 
Przejściowa_Kolekcja_Jesienna Lightweight
 
1
Webio Replied
Small update here. On Android device (v5.1) and Pebble smartwatch (but this is connected to Android device) I'm also seeing underscores instead of empty spaces.
1
CCC Replied
We have also had reports of this from people using the SmarterMail Webmail client
1
Stefan Mössner Replied
Hello together,
 
I can confirm this issue, too.
 
After upgrading SmarterMail to 14.3.5752 there are subject lines at some mails where the spaces are replaced by underscores. The mails are from outside my internal mail domain, where I can see the underscores in the subject lines. But not all mails from outside my internal mail domain are showing this issue. I'm only working with the webmail interface.
 
Kind Regards
0
Paul Blank Replied
Right. Webmail issue (ok, for one). 
0
Webio Replied
I've seen emails (few of them) with this issue on my Android device fetched using Activesync so IMHO not only webmail.
1
Webio Replied
Issue has been reported using support ticket.
0
Paul Blank Replied
I am Interested in ST's comments on this thread. 
 
1
Michael Replied
We are seeing same from some not all senders.
2
Brian Ellwood Replied
No comment from the staff yet?
 
I always get > < close to pushing to version 14 then another bug rolls around that makes me glad I've waited :/
0
FlexWS Replied
I have also seen underscores in the subject where the sender name contains a special character like é
0
Paul Blank Replied
A little surprised that there is no response from ST on this.
0
Michael Replied
Smarter Tools.. are you seeing this?
0
Employee Replied
Employee Post
Hi Michael. Webio has submitted a support ticket related to this. We are currently looking into this.
2
Employee Replied
Employee Post
Hello all.  Our developers have found the cause of this.  They're currently testing a fix, and I'll post a custom build as soon as I receive it.
0
Bruce Barnes Replied
Isn't Pebbles a bit young to be wearing a smart watch?
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
3
Employee Replied
Employee Post
Hello all.  I have a build that will fix this issue.  Please uninstall your current version of SmarterMail 14, and then install this version:   http://www.smartertools.com/downloads/SmarterMail/CustomBuilds/14.3.5770.16838/SmarterMail14_Setup.exe
0
Stefan Mössner Replied
Hi Rod,
 
I installed the customer build and for the first sight it looks good that you fixed the issue. I will look at this the next days and will give you feedback.
 
Thank you for the great work.
 
Kind Regards
 
Stefan
0
Stefan Mössner Replied
Hi Rod,

after nearly one week I can confirm that there are no underscores as replacement of space when working with the web mail frontend.

Kind Regards

Stefan
0
Brian Ellwood Replied
When can we expect an official release? 10/01/2015 was the last 14.x update
0
Robert Emmett Replied
Employee Post
We are tentatively looking to release later today, 29 Oct. Obviously, this is submit to change.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Brian Ellwood Replied
Thank you =)

Reply to Thread