Smartermail not recieving mail on azure
Problem reported by Kenneth Voss - 9/14/2015 at 8:46 AM
Submitted
I've been having smartermail server running under azure VM for quite a while now, after migrating VM to another subscription I don't recieve mails anymore- outgoing mail still works!!
 
domain is seesharper.dk
 
Any help would be appreciated
 
- Kenneth 

7 Replies

Reply to Thread
0
Bruce Barnes Replied
You haven't setup a HOST RECORD for your MX server
 
You need to setup an A or HOST record for you MX server so that MAIL.SEESHARPER.DK points to 137.135.140.169
 
NOTE:  YOU CAN NOT USE A CNAME RECORD FOR MAIL SERVERS - CNAME RECORDS ARE NOT ALLOWED.
 
As a matter of general principal, you should avoid using CNAME records whenever possible and create HOST records.
 
Mail Servers Have A No Records
FAIL: I've found mail servers without A records:
  • -- mail.seesharper.dk. → ?
To reach your mail servers via IPv4 an A record is needed for each mail server.
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
Kenneth Voss Replied
Like this??

Thanks for helping by the way :)
0
Employee Replied
Employee Post
Hi Ken.  I'm still not seeing valid MX records for your domain.  You can see that here.  If you have indeed added MX records to your DNS, then that may take time to propagate.  
0
Kenneth Voss Replied
Hi Rod.

Could you pls guide me to set up valid MX records for my domain??

- Kenneth
0
Bruce Barnes Replied
Kenneth: will need several different DNS records for your e-mail to function properly.
 
HOST record, mapping the FQDN of your MX server to the PUBLIC IP ADDRESS on which the server is installed
MX record, mapping the SmarterMail server to the HOST record you setup avove
rDNS record, mapping a REVERSE of the host record, back to the IP address.
 
Then there are several elective records, all of which are highly recommended:
 
Here are a few examples, based on having SSL/TLS enabled and using IIS, vs the SmarterMail web server, which is designed only to get SmarterMail setup.:
 
 
 
 
 
 
 
A good beginner's guide to DNS is DNS and BIND from O'Reilly.
 
 
You may also be able to find outtakes of various sections, as PDF files, via a Google search.

Remember, too, that you'll need to
 
  • setup the ports in SmarterMail
  • map the ports to your IP ADDRESS
  • map your IP ADDRESS to the FQDN of your SmarterMail HOSTNAME
  • setup an rDNS to HOSTNAME MAPPING through your internet bandwidth provider, in this case, Azure
 
and, once that's done, you'll need to open the ports for each of the items mapped above in your firewall.
 
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
Kenneth Voss Replied
I did above - and still not working.. I can send mail internally when on server, but not from google to my mail, port 25 is open in firewall but cannot connect from tellnet unless I use local ip port 25
0
Bruce Barnes Replied
Sounds like you do not have local to PUBLIC, STATIC IP address mapping configured in your router or firewall.
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting

Reply to Thread