v14 - New appointments shown twice on Android EAS
Problem reported by FlexWS - 6/13/2015 at 1:48 AM
Submitted
We have upgraded SmarterMail to version 14.
 
If I create a new appointment from my Android phone (4.1.1) every new appointment shows up twice at the same time. If I look at the webmail client / iOS EAS / Outlook 2013 EAS it is only shown once.
So it seems Android EAS specific?

11 Replies

Reply to Thread
0
CCWH Replied
I have tried to recreate this issue but it all works fine for us.  Using Android 4.2 & 5 with SM v14 Ent & Pro.  Ran a sync from Outlook 2013 (EAS) and then created the meeting on Android....only one meeting showing on all devices.
 
 
0
FlexWS Replied
I reinstalled my EAS account on my Android phone just to make sure.

The only thing I have to do is create an appointment on my Android device (running Android 4.1.1) and sync it. (the server is running SmarterMail 14.0 Enterprise). Now I have two appointments on my Android device, both at the same date/time.

SmarterMail web interface only shows one appointment at the given time.

I'm not sure if one of the appointmets is only a "local Android" appointment, or if there is actually only one appointment but Android thinks there are two.

This happened since I upgraded the server to version 14.
0
CCWH Replied
Very weird. The only different with my tests compared to yours is the Android version. Can you test on another Android device? Are you using the Android built-in Mail app for ActiveSync?
0
FlexWS Replied
Hi, I created a new EAS account within the same domain and installed it on the same Android device. Everything works as expected with that new account, which would make my problem account specific for the first account...

Testing on another device with the same EAS account creates only one appointment and does not duplicate after sync. That would make the problem account+device specific.

Appointments created on the first device do show up in the webinterface once (twice on the device itself), but I didn't get them on my second device when I synced. If I delete the appointment from the webinterface, one item remains on the Android device, where they were shown twice. One of the two appointments seems to be the actual synced item. If you delete the "correct" item, both of the appointments disappear after sync. If you try to delete the other item, one item will remain on the device, but synchronization seems kind of broken at that point and Android keep throwing a synchronization error when you try to sync manually. After deleting other portions of the duplicates, the synchronization started to work again after a little time (not sure if this is just time related, or the appointments really have to be deleted). The next sync gives one appointment back to me, that's is the one that was "incorrectly removed". The other one seemed to be "correctly removed" and was not coming back. "Correct" and "incorrect" removal seems to be deleting the first or the second appointment that is displayed on the same time.

Appointments created on the second device work as expected. This device also runs Android 4.1.1
So the problem seems a combination of my EAS account with my primairy device.

Maybe it is a coincidence that it started behaving this way after our v14 upgrade, but it really is a little weird :)
0
FlexWS Replied
For the record: I just tested the behavior with another EAS account using a different device, but the same model. Seems to work fine.

So it is just a combination of my account on my device what suddenly started to happen. I guess SmarterMail couldn't do anything about it, but it's just a really really weird combination that it is only my account on my device after the v14 server update.

I guess I have to live with it or find another work-a-round, or completely reset my phone or something. I'm stuck here, but I'm also (almost) convinced that this might not be a bug or something like that after all....
0
Bruce Barnes Replied
Did you try deleting your account from your phone and re-creating it?  That's been a fix for Android devices for all kinds of issues.
 
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
FlexWS Replied
Yes, first line of my first reply.
I reinstalled the account a couple of times, but didn't make any difference. Maybe some other data files are left behind that make this problem happen.

I could try to delete every e-mail and calendar account and try it again or else I think the only option left is completely factory-reset the phone...
0
Bruce Barnes Replied
Android 4.1 is pretty old at this point.  Even LG, who is notorious for lagging on updates, is up to Android 4.4.
 
Sprint has already pushed Android 5.0 on Samsung devices and is getting ready to push Android 5.1.1.
 
Make certain you have updated the Android operating system on your phone to the latest version supported by your carrier and see if that helps.
 
You should also make certain, if you have not done so already, that all of your Android APPS are up to date as well.
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
Matt Petty Replied
Employee Post
I have a LG G3 that runs 5.0, LG does lag behind but they are at least on 5.0, despite it being a buggy version.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
FlexWS Replied
All apps are up to date but HTC stopped updating Android for the device (One S) very soon some while ago. The device itselfs works fine, so no need to replace it, and it has worked forever before.

As said another One S still works fine, that's the strange thing about it, so it's somewhere in my device or something.
0
Bruce Barnes Replied
In my experience with LG products, they bend over backward to ensure customer satisfaction.  Have you attempted to contact them and ask them if they are aware of any issues with their customizations of the Android calendar APP?
 
While they may not have made actual customizations to the calendar APP, both the device manufacturers and carriers, frequently modify the underlying base code prior to pushing to specific devices.
 
If they don't have any suggestions, then perhaps you are right and a complete factory reset of your device is in order.
 
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting

Reply to Thread