NOT WORKING - download all attachments
Problem reported by Lawrence McElhinney - November 7, 2014 at 9:50 PM
Not A Problem
Version:  SmarterMail Enterprise Edition 10.7.4842
 
If someone sends me an email with multiple attachments, lets say 10 images, the "Download All Attachments" link is no longer working correctly.
 
When you click the link, the ZIP file will open but all of the files in the archive have the same exact name.  It is therefore impossible (or difficult) to Extract the files to a folder.
 
When this feature was working, you would simply click the "Download All Attachments" link and the Zip file would have all of the attached files with their unique file names.
 
Anyone have any ideas for a solution?
 

9 Replies

Reply to Thread
0
John Marx Replied
I just tried several emails that had multiple attachments on v13 with no issues at all. Have you tried other emails or just the one? Have you updated to the latest version?
0
Lawrence McElhinney Replied
Version: SmarterMail Enterprise Edition 10.7.4842
0
John Marx Replied
Being it is an older version I would do a full uninstall, reboot, and the install just as you would a full version if you can't upgrade to the newest version. I know if a file gets corrupt, etc. doing a re-install will fix those issues and takes 5-10 minutes typically.
0
Nvard Khachatryan Replied
Same issue on SM 12.5 ent.

Sometimes it works, sometimes - not. I'm sure its a bug, but have no time to check when exactly it happens.
0
Robert Emmett Replied
Employee Post
What browser are you using? FireFox 33.0 has had some issues with downloading files in general, which they have stated will be fixed in their next update.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Nvard Khachatryan Replied
As previously commented, Same issue on SM 12.5 ent. Sometimes it works, sometimes - not.
 
Ok just played a little and found out the problem source, I think.
 
Actually, the problem is not connected to number of attachments. It may come out even with 1 attached file. The real problem is with .zip file generated by SM.
 
Let me explain the problem. For some messages Download all messages link works pretty well, for others - it gives out "corrupt" zip file. The following described for a message with corrupt  Download all messages zip file.
 
When you click download all files, the zip file is downloaded and saved, as expected. After double-clicking the file, it is opened by windows explorer build-in zip unpacker, but no file is displayed, as if the zip file is empty.
 
However, the file may be  several MB in size. Tried to open the archive with 7zip program and ooops, it did its job! But.... the .xls file in .zip archive is without extension! After renaming the file within 7zip shell, the zip archive starts working within windows build in zip unpacker.
 
I'm not sure the problem is connected with missing extension, may be the 7zip rebuilds the archive after renaming and it becomes usable within windows. Actually, I'm not aware how zip works.
 
Tested with SM 12.5. If someone interested, leave an email address and I'll send a message with un-openable Download all messages link.
0
Joe Joe Replied
Hi,
 
i install smartermail 16 and also get the issue,
the downloaded files shows both
 
AllAttachments.zip  0KB
AllAttachments.zip.part  17KB
 
and unopen-able,
is it normal ?
 
 
thanks
0
Tim Uzzanti Replied
Employee Post
Are you able to replicate this?  Is this listed in the Attachments Tab for the message?
 
We are not aware of any issues with AllAttachments and/or can I replicate on my account.
 
If you can provide more detail, maybe we can help.  
 
If this continues for you, we might need you to open a ticket because it would be unique to your mailbox / server.
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Joe Joe Replied
Hello,

i test it again,it works now.
as another thread ask,im not sure if i restart smartmail fix the issue.

thaks

Reply to Thread