Can I prevent spam from being forwarded with a custom rule
Question asked by Donald Ferguson - 10/30/2014 at 12:59 PM
When spam messages are received I have filtering set to append text to the subject line (SPAM-LOW:, SPAM-MED:, SPAM-HIGH:) .
Next I set up a custom rule that blocks outgoing mail if the subject contains SPAM-HIGH. This rule is enabled for Outgoing SMTP Blocking only. Not Filtering or Incoming.
    Rule Source: Header
    Header: Subject
    Rule Type: Contains
    Weight: 50
    Rule Text: SPAM-HIGH
Finally, I have my SMTP Blocking enabled for Outgoing with a weight threshold of 45.
With this setting, I don't see any blocked outgoing messages in my system statistics >> security dashboard. The only reason that I can think of for this is that the messages are being forwarded before the incoming mail filters are applied.
Is this the case? If so, Is there any way to have the incoming mail filters applied before the email is forwarded to any other accounts?

Reply to Thread