Why can't I access SmarterTrack/SmarterStats with the NetworkService Application Pool Identity?
Question asked by James Jenkins - 10/22/2014 at 8:47 AM
After a successful install of SmarterTrack 10, I choose to add the application to IIS 8.5 on a Server 2012 R2 system. Unfortunately, when trying to view the webpage I got an error message of:
The page or resource that you are accessing is unavailable or an error has occurred.
When troubleshooting, I changed the Application Pool Identity from "NetworkService" to the local Administrator account. Doing this allowed me to view the webpages without issue. I understand that there are security concerns when doing this and would prefer to have this configured right.
Since then, I tried going to the MRS folder and adding "NetworkService" to the ACL list with Read only permissions. This has not helped.
Please note that I have the exact same issue when adding SmarterStats 9 to IIS.
Can someone please tell me how to resolve this issue?

2 Replies

Reply to Thread
James Jenkins Replied
Sorry I made a mistake. Smarterstats is now working with the "NetworkService" Identity. SmarterTrack is not.
I tried changing the Identity to "LocalSystem" and this works for both SmarterStats and SmarterTrack. Are there security concerns in configuring it this way? I tried researching this but am confused.
Employee Replied
Employee Post Marked As Answer
Hello James,
Thanks for the information. You may want to make certain that the MRS folder in the SmarterTrack folder has Full control for the NetworkService account. The Read only permission would not be sufficient in this scenario.
Thank you.

Reply to Thread