Missing X-SmarterMail-TotalSpamWeight
Problem reported by Erick Baum - October 6, 2014 at 9:44 AM
Submitted
It seems that since one of the recent upgrades, the X-SmarterMail-TotalSpamWeight is missing from messages forwarded to Incoming Domains.  Was this by design or did this get removed on accident?  We used that to filter spam on the Exchange servers we forward mail to.  Can it be put back somehow?

7 Replies

Reply to Thread
1
Erick Baum Replied
No one knows anything about the X-SmarterMail-TotalSpamWeight header missing?  Why?  How to get it back?  Nothing?
0
Steve Reid Replied
Of course this was never removed. Every one of the emails that goes through my server has this always.
 
Did you turn off spam checks?
0
Erick Baum Replied
Sorry, I meant it's missing from the incoming gateway domains. When a message is forwarded to an incoming gateway server, that's when it loses that header. It's present on regular internal domains. This only happened recently.
0
Steve Reid Replied
I believe this may be why my backup MX was not passing spam scores to my main server...
 
I had to turn of spam checks on the backup and just let the main box scan everything.
0
Steve Reid Replied
http://portal.smartertools.com/community/a549/spam-making-it-though-backup-mx.aspx
0
Erick Baum Replied
We have two SmarterMail MX servers in front of our main server but they do not have any spam checking enabled. We just do everything at the main server. But this is only happens to domains setup as Incoming Gateways. I don't understand why SmarterTools would have removed the total spam score from gateway domains. It was really handy so we could mark their spam and their mail server could filter it accordingly.
0
Webplusidc Replied
Same problem Erick.
Here we have an Incoming Gateway that perform the basic dns checks and send messages to a remote SpamAssassin server for spam check. When the message return to the Main MX Server, it comes without the Weight.
This problem started on version 11.7 and wasn't fixed until now (13.4).

Reply to Thread