"Spam Check" option will not stay ticked - SpamAssassin will not activate
Question asked by Kevin Russell - 9/26/2014 at 3:01 PM
Answered
Hi
 
In Security/AntiSpam Administration/Spam Checks I tick the "Spam Check" option and "SpamAssassin-Based Pattern Matching" and click save and get a message "The settings have been saved".
 
If I come out of SmarterMail and go back in the options are unticked. Any Ideas?
 
I have 10.7.4842 installed in Windows 2008 R2
 
Regards
Kevin Russell

15 Replies

Reply to Thread
0
Kevin Russell Replied
I need some help with this - can someone tell me if there is anything I can look at?
0
Steve Reid Replied
Sounds like a permissions issue where the files cannot be written to.
0
Robert Emmett Replied
Employee Post
Are you checking "Enable for Filtering" and/or "Enable for Outgoing SMTP blocking" before clicking save?
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Kevin Russell Replied
Yes. After the settings have been saved, I click on another Security option - i.e. Blacklist, click back to Antispam Administration and the Spamassassin option is unticked again.
0
Scarab Replied
I had this problem recently too. For me it was a sign that the MailConfig.xml had corruption and was about to be truncated. I posted about this at: http://forums.smartertools.com/threads/421-442-and-554-smtp-errors-resolved.42695/#post-137561.
 
Although it could also be a READ-ONLY flag on the MailConfig.xml or incorrect Permissions that could cause the same problem. However, if neither of these cases apply, try stopping the Smartermail Service, restoring an earlier MailConfig.xml from backup, and restarting the Smartermail Service and see if the inability to save the Anti-Spam Settings in Smartermail goes away.
0
Bruce Barnes Replied
Did you remember to save the settings before navigating to a different page and back to the antispam settings again?
 
The save step is independent of clicking on the boxes and must be performed to complete the process.
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
Kevin Russell Replied
I checked the Config file and it is not Read Only. I restarted the SmarterMail service but no joy. I restored a couple of previous Config files, no joy.

The "Spam Check" tick box clears immediately when I click "Save Settings" - is this normal?
0
Kevin Russell Replied
The "Spam Check" tick box clears immediately when I click "Save Settings" - is this normal?
0
Steve Reid Replied
I think you talking about the "select all" check box at the top left...

Maybe you should read up on Bruce's spam document to see what proper settings look like.
0
Steve Reid Replied
Marked As Answer
The only valid check boxes are the three columns on the right.
 
You are talking about the select column on the left. Which is not an enable option.
0
Kevin Russell Replied
Steve,

Ah. so if I tick the "Spam Check" or "Spam Assassin-based Pattern matching" options, they shouldn't stayed ticked?

And only the "Enabled for filtering" and "Enable for outgoing SMTP Blocking" are relevant? These options do indeed stay ticked.

Thanks for the replies so far!
0
Steve Reid Replied
Yes indeed sir, now you got it!
0
Kevin Russell Replied
Can I have a link to Bruces Spam Document please?
0
Steve Reid Replied
http://portal.chicagonettech.com/kb/a171/smartermail-antispam-settings-document.aspx
0
Kevin Russell Replied
Tick boxes are supposed to be ticked :-) I now see my confusion. Couple with the inordinate amount of Spam that is getting through at the moment I go into a tailspin. Thanks Steve, Bruce etc.

Reply to Thread