SpamAssassin server socket error
Problem reported by Brian Henson - April 9, 2015 at 2:03 PM
Submitted
In the delivery logs I'm seeing spamassassin is getting a socket error trying to connect to 127.0.0.1 on port 783.
 
This port should be open, I don't have it blocked by any firewalls. What could be the problem?

7 Replies

Reply to Thread
0
Joe Wolf Replied
What does SmarterMail show if you go to Security | Advanced Settings | SpamAssassin Servers?
Thanks,
-Joe
0
Steve Reid Replied
You need to be running a spam assassin server like Spam Assassin in a box for this to work. If I got this error it would mean the Spam Assassin in a box service was not running.
0
Brian Henson Replied
It says "DP-Mail02 (Down) (0:38 remaining)" status is "Inactive", IP Address is "127.0.0.1" and Port is "783". I don't see anything like "spam assassin in a box" in the SmarterMail documentation.
0
Steve Reid Replied
Spamassassin is not included with smartermail
0
Brian Henson Replied
Is spamassassin necessary at all? We migrated smartermail to a new server and now that I'm looking at the old server it appears that spam assassin in a box was installed, but this wasn't documented.
0
Steve Reid Replied
Its certainly not required... I use it. But you can just disable it
0
Richard Frank Replied
I am sorry to revive this old topic but I read this in the KB
SmarterMail includes a Windows version of SpamAssassin out of the box. By default, SmarterMail will run a version of SpamAssassin on 127.0.0.1 port 783. The System Administrator can enable and disable SpamAssassin through the Anti-Spam Administration link in the Security menu.
So.. SpamAssassin should work?

Reply to Thread