Send & Receive Errors in Outlook 2013 & Windows Live Mail
Problem reported by Scarab - 3/13/2015 at 9:53 AM
We have recently been getting dozens of reports of accounts receiving the following errors on a regular, reoccurring basis:
  • "Task 'server name - Sending and Receiving' reported error (0x800ccc0f): 'The connection to the server was interrupted. If this problem continues, contact your server administrator or Internet service provider (ISP)."
  • "Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Error number: 0x800ccc0f"
  • "Task 'SMTP server name - Sending and Receiving' reported error (0x80042109): 'Outlook is unable to connect to your outgoing (SMTP) e-mail server. If you continue to receive this message, contact your server administrator or Internet service provider (ISP).'"
  • "A time-out occurred while communicating with the server 0x800ccc19"
  • "Your IMAP command could not be sent to the server, due to non-network errors. This could, for example, indicate a lack of memory on your system."
  • "Unable to send or receive messages for the ****** account. Header download for the 'Inbox' folder did not complete. Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity."
It seems most prominent with Windows Live Mail where it occurs every 15-30 minutes (especially on IMAP accounts with several GB of email), although Outlook 2013 is throwing Send/Receive errors as well in both IMAP & POP, but it is more transient and recovers a few seconds later.
For us the problem seemingly began with v13.1.5451, but it has gotten far more common since updating to v13.3.5535.
Increasing the Server Timeout in email clients doesn't resolve the problem, although it may be useful to note that Apple Mail, Thunderbird, and Outlook 2003 customers do not seem to ever experience this problem. It is apparently just Outlook 2013 and Windows Live Mail clients (not sure about Outlook 2007).
In the detailed logs there doesn't seem to be anything amiss. I've been trying to get some customers to enable Diagnostic Logging in their email clients so we can trap what may be causing the errors.
For reference this is a bare-metal server with Windows Server 2008R2 Enterprise, Dual Xeon X3450, 16GB RAM, and 15K SAS Drives, Dual Intel Gigabit NICs (82574L). This Mail Server only handles client connections (we have separate servers for Incoming & Outgoing Gateways that handle email delivery and all Spam checks). Although we support around 10K users & 35K-65K emails/day, the average number of connections at any given point in time is @ 400 (Avg CPU is 1%, Avg Memory is 1900 MB, Avg Handles is 2286  and Avg Threads of 71). We've been running Smartermail Enterprise for a decade now.

8 Replies

Reply to Thread
Hemen Shah Replied
I too have been facing this since last update frequently, what i have noticed is when i get this error (send/receive) at the same time check your ISP IP would getting blocked for Denial of POP service, mostly ISP IP would be dynamic and hence this would resolve if you reboot the router.
Also to note that this would be happening where same user id is configured in multiple systems or incoming flow is high, i too have not solution to this as of now but tried tweaking the send/receive time interval in all systems but still not much help.
If not above issue then other could be outlook pst file size which could be too high or some corruption in which you can try running the scanpst.exe file to repair and try.
Scarab Replied
I've tracked down the problem, somewhat...
These errors are occurring when the Smartermail Mail Server reaches 500 IMAP Connections. Although in SETTINGS > PROTOCOL SETTINGS > IMAP I have 4000 set for "Max Connections", no new IMAP connections can be made when there are already 500 IMAP Connections to Smartermail.
Assuming that this may be a Windows Server problem I tried the following:
"netsh int tcp set global autotuninglevel=disabled"
"netsh int ipv4 set dynamicport tcp start=1025 num=64500"
"netsh int ipv4 set dynamicport udp start=1025 num=64500"
This unfortunately did not resolve the problem and it still exists when Smartermail reaches the 500 IMAP Connections.
I have also tried setting Max Connections for IMAP in Smartermail to 0 (unlimited), yet problem still exists when reaching 500 IMAP Connections. 
Anyone have any idea what else could be causing this or how to resolve it?
Scarab Replied
This is resolved. Restarting IMAP in Smartermail wasn't enough for the changes to the SETTINGS > PROTOCOL SETTINGS > IMAP to occur. The Smartermail Service needed to be restarted in Windows Server for the changes to be applied.
Michael Muller Replied
I'm having a similar problem where I get the message "Your IMAP server has not responded in 60 seconds. Would you like to wait another 60 seconds for the server to respond?"
The client has three IMAP accounts in Windows Live 2011, and the only one that drags like this is my SmarterMail 13.1
Any thoughts?
Montague WebWorks
Powered by RocketFusion
Michael Muller Replied
If I click the Stop button, sometimes I get this:

The server did not respond to this IMAP command before the connection was terminated.

   Account: [account name]
   Server: imap.montaguewebworks.com
   User name: [email address]
   Protocol: IMAP
   Port: 143
   Secure(SSL): 0
   Code: 800ccc0f

Montague WebWorks
Powered by RocketFusion
Bruce Barnes Replied
As more MX server operators upgrade their server operating systems to disable SSL and enable TLS - following the mandates of the retirement of SSL as a valid encryption protocol, we are seeing this a lot.  In fact, I've spent the last two weeks helping MX server operators sort this out and develop resolutions for their hosted customers.
Some server owners and operators actively applied patches and/or fixes for the SSL/TLS updates.  Others used tools - many of which did not do a particularly good job, either; and still others manually manipulated their registry entries to effect the required changes.
The problem was created because the SSL ports, which were formerly valid, are no longer encrypted because the SSL V1.0, V1.1, and V1.2 are not encrypting any longer and the connections fail.
So, now the logical question:  did you recently update your server's registry settings to get rid of SSL and enable TLS, per the requirements of the depreciation of SSL as a valid encryption?
If so, are your customers using SSL during their IMAP connection attempts to your SmarterMail server?
If you recently enhanced the security of your server by disabling SSL, and enabled TLS, and your customers are still using SSL IMAP, they should change to TLS IMAP on port 587 because the SSL ports are no longer valid.
QUALYS SSL Labs has some really good information about all of this at: https://www.ssllabs.com/projects/documentation/
You can test your MX server, via their testing tools, at: https://www.ssllabs.com/ssltest/index.html, making certain to use the FQDN of the domain on your SmarterMail server to which the SSL certificate is issued when you test, IE: our SmarterMail server's FQDN is securemail.chicagonettech.com, so that's what we tested at QUALYS SSL Labs 
Bruce Barnes
ChicagoNetTech Inc

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
Michael Muller Replied
I don't have an SSL certificate on my server (yet) and have not had any problems with any other accounts, except this one, which was using Windows Live 2011.
The solution was to use Thunderbird instead. Problem solved.
Montague WebWorks
Powered by RocketFusion
Bassem Rawas Replied
I'm using version 10.7.4842. Only lately started having the above problem with error 0x800CCC0F "the connection to the server was interrupted". we are not using SSL, only about 50 users, and it's happening on outlook 2007, 2013, 2016. POP, and IMAP users. We have a static IP so restarting the modem suggestion above won't work for us. I tried Scarab's suggestions but they didn't seem to help either.

Reply to Thread