SmarterTrack Failed to connect to the SMTP server
Problem reported by Neill Toms - 2/9/2015 at 6:46 AM
Submitted
Hi,
 
I am having a bit of trouble getting my SmarterTrack 8.6 to send mail, now before you ask i have triple checked the details in the SMTP field and I'm 100% sure they are correct. the stats system fails to connect, the mail server is SmarterMail 10.7 Pro and hosted on the same server.
 
other systems such as WHMCS (also hosted the same way) connects fine. so have i got a permissions issue and if so how to fix?

9 Replies

Reply to Thread
0
Employee Replied
Employee Post
Do you see any attempt to connect in the SmarterMail SMTP logs?  If so what error message is being shone?  If you do not see any connection attempt try to telnet to your mail server using the same settings that SmarterTrack is using and see if you can make a connection.
0
Neill Toms Replied
It's not even showing in the smarter mail log, so it's not even getting that far!
0
Employee Replied
Employee Post
When you telnet what type of response are you receiving?  Also are you using the IP address or hostname?  If it is the hostname try the local IP address since they are on the same box.
0
Neill Toms Replied
Ok after looking through logs the smartertrack SMTP is trying to connect via IPv6 which smarter mail 10.7 doesn't support. I've tried to us an IP, but because it is effectively 'localhost' it defaults to using IPv6. Is there any way to change this? Or allow smartermail to bind an IPv6 my server has?
0
Employee Replied
Employee Post
To change what IP address SmarterMail is listing on login as the system admin and go to Settings | Bindings | IP address then edit the IP address you want SmarterMail to listing on and enable/check the proper protocol.  Also if you do not want SmarterMail to listen on an IP address make sure all ports are disabled/unchecked for the specified IP.
0
Neill Toms Replied
Yep that's fine but windows server 2008 r2 when an IPv6 is available it favours it, smarter mail does not support it? Which if you ask me is astonishing considering IPv6 has been around since 1998 and you happen to put in smarter mail v11 (seems like this is a ploy to buy the updated version) smarter track on the other hand obviously supports it because it keeps trying to us IPv6 to connect. Now I've tried localhost, the servers main IPv4, 127.0.0.1 and also mail.blabla.co.uk bound using an a record. But because it detects it's the localhost (via servers DNS) it always defaults to the IPv6 available.... This is a major flaw and should be addressed in smarter mail by allowing us of IPv6 in smarter mail 10.7 Surely people at the time was having the same issue considering IPv6 has been around a while now and compatability is key if we are to move forward with the dynamic of IPv6 being the way forward? My suggestion would be launch an update to the mail server that allows us to use our IPv6.
1
Employee Replied
Employee Post
Hi Neill,
 
As you noted we do have IPv6 support in SmarterMail 11 and later and at this time we will not be adding any new features to SmarterMail 10.  You should still be able to use SmarterTrack and SmarterMail 10 event without IPv6 support.  At this time to further troubleshoot this issue we will need access to your server and this will require a support ticket. 
0
Neill Toms Replied
Haha, which cost money.
0
Shane Hollis Replied
I didnt see any attempt to connect as servername.domain.local. This may get around the local host issue. Alternatively, on your server edit your hosts file and put in a domain like support.local and attach an ip4 address to it e.g. 192.168.1.1 support.local - that will allow smarter track to use the local host without using localhost and get around the issues.

Reply to Thread