[solved] Problem mit SmarterMail 12 and 13 on Win Server 2008 R2 with IIS
Question asked by Fred Jelk - January 12, 2015 at 6:20 AM
Unanswered
Hello,
I have a problem with SM 12 and 13 on my Windows Server 2008 R2 with IIS.
If I install SM 12 and 13 and use the internal Webserver, I can access to the SmarterMail-interface. But if I stop the internal Webserver and activate the IIS with .net4, and I want to access to the SmarterMail-interface, I got an error-message: Runtime Error in Application /.
I made the installation according http://portal.smartertools.com/kb/a2766/set-up-smartermail-as-an-iis-site-iis-7_0-7_5.aspx
 
What could be the problem?
 
So I have reinstalled SM 11.7. With this version, it works with the IIS. But I would like to use a newer version.
 
Best regards
Fred

2 Replies

Reply to Thread
0
Employee Replied
Employee Post
Good day Fred,
 
Thanks for the inquiry. Can you please provide us confirmation from either the SmarterMail 12x or 13x installation the error logs from the following folder:
[C:\Program Files (x86)\SmarterTools\SmarterMail\MRS\App_Data\Logs]
 
We would presume that there may have been a specific issue with the upgrade that the error log may point to.  If you are in a position to upgrade to a test server please let us know the results. One thing to remember is to check the application pool identity to see if the account, possibly the Network Service has full control over the SmarterTools folders. You may also want to confirm that the Managed Pipeline mode is set to 'Integrated' apposed to 'Classic'
 
Thank You.
0
Hi Joe,
I'm sorry, I have deleted de logs, everytime, when I installed SM11 again.
But I have solved the problem:
According an other thread in this forum, I have tried the msi-installer instead of the exe-installer. With the msi-installer, it works now. I think, the exe-installer of the version 12 and 13 there is something missing.

Reply to Thread