SMTP In Banner #HostName# displays primary domain only
Question asked by Brian Arlinghaus - January 8, 2015 at 5:16 PM
Answered
Is #HostName# supposed to display the hostname of the IP address on which the SMTP connection is made?
 
I have about 10 domains.  The SMTP Banner only displays the hostname specified in General Settings | Server Info | Hostname.
 
Why doesn't it display the hostname associated with the IP Address?
 
Thanks

4 Replies

Reply to Thread
1
Employee Replied
Employee Post Marked As Answer
Hi Brian,
 
If you want each domain to have its own host name you need to do the following steps.  This does assume you have enough IP address for each domain that you want to have its own host name.
 
Login as the system admin and edit the domain.  Go to the Technical Tab and specify the Outbound IP address.  Then go to Settings | Protocol Settings | SMTP Out tab and change Outbound IP setting to "Use the domain IP".    After this go to Settings | Bindings | Hostname and add the outbound IP address with the appropriate host name.  This will only work if each domain has its own IP address.  If two of more domains share the same IP address it will default to the first one listed.
0
Thanks!!! I was missing the hostname. I was wondering what that was for. I just figured that it would use the the default domain name automatically. Brian
0
Indika Liyanachchi Replied
Hi 
I have the same issue in my server. I checked with mxtoolbox and it gave me this errors. 
After that, I checked my reverse DNS lookup and it was https://www.whatismyip.com/reverse-dns-lookup/
Host Name for 1.0.4
Host Name: m2404.contaboserver.net
 
But my mail servers domain is mail.eweblook.com and it is hosted on m2404.contaboserver.net server how should I fix this? 
0
Nicolas Fertig Replied
- Ask your service provider to change the reverse DNS of your ip 193.200.241.41 to mail.eweblook.com

or

- change your mailserver hostname to m2404.contaboserver.net

Either way should work. What is important is that the reverse lookup of the ip matches the configured servername in the greetings/helo.

Reply to Thread