1
New Installation epic fail.
Problem reported by network admin - February 16 at 12:37 PM
Resolved
This is not what I would expect for a clean new installation.
 
Fresh 2012R2 install and updated completely.
Fresh install of Smartermail16 Beta take all default installation locations
and I get this:
 
HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.
Detailed Error Information:
Module       IIS Web Core
Notification       BeginRequest
Handler       Not yet determined
Error Code       0x80070021
Config Error       This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".
Config File       \\?\C:\Program Files (x86)\SmarterTools\SmarterMail\MRS\web.config
Requested URL       CANTUSEHYPERLINKSINPOST://beta.XXXXXXXX.com:9998/
Physical Path       C:\Program Files (x86)\SmarterTools\SmarterMail\MRS
Logon Method       Not yet determined
Logon User       Not yet determined
Config Source:
   40:         <validation validateIntegratedModeConfiguration="false" />
   41:         <handlers>
   42:             <remove name="ExtensionlessUrlHandler-Integrated-4.0" />
More Information:
This error occurs when there is a problem reading the configuration file for the Web server or Web application. In some cases, the event logs may contain more information about what caused this error.
View more information »

2 Replies

Reply to Thread
0
Rod Lasky Replied
February 16 at 12:43 PM
Employee Post
Hello.  That error looks like IIS might be having an issue accessing web.config.  Can you make sure Network Service is running the SmarterMail application pool, and that it has full control over the C:\Program Files (x86)\SmarterTools\SmarterMail\MRS folder.
Rod Lasky
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
network admin Replied
February 16 at 1:14 PM
Actually that was what I checked before sending this.  But.  Double checked the application pool.
Application pool is set to .NET CLR Version v4.0.30319
Managed Pipeline Integrated
 
Also double checked and fixed permissions for Network Service to have Full Control on MRS folder.  Stopped and restarted the server.  Rebooted it as well. Same error
 
Changed permissions on Windows\Temp for Network Service to FULL CONTROL
But the other one the Temporary ASP.NET files I do not have..... Am looking

Reply to Thread