2
SM 14.4 Add GAL to Outlook Broken
Problem reported by Steve Vibert - February 5, 2016 at 5:21 AM
Submitted
We’re  running SM 14.4 Enterprise and discovered that the contacts “Add to Outlook” action for the Global Address List no longer works.  With the GAL selected,  “Add to Outlook” always adds contacts from the personal address book to Outlook.
 
We use Outlook 2010 and are in the process of setting up over a dozen new laptops and need to add GAL SharePoint lists to these machines so this is pretty disastrous. 
 
[EDIT]
And while we can export contacts from SM and import them into Outlook, we lose the dynamic updates (user info changed, new user added, user deleted, etc.) that the SharePoint lists provide.  Apparently, this is borked as well; some of the email address fields contain personal email addresses -- arrrrg.
[/EDIT]
 
Any thoughts as to how to work around this?

4 Replies

Reply to Thread
1
Steve Vibert Replied
February 7, 2016 at 2:20 PM
Update:Rebooting the server seems to have fixed the GAL "Add to Outlook" action.  However, many of the email address in the Outlook SharePoint list contain personal email addresses rather their domain email addresses.  I initially suspected that these users might have entered their personal email addresses in "My Settings>Account Settings>Reply-To Email Address" or "Backup Email Address" but all of the ones I looked at these fields either blank or in the case "Reply-To Email Address" had their domain email address.  Nor for that matter was their personal email address to be found anywhere in the "Account Settings" or "Account Profile settings. 
 
Looking at the ones with personal email addresses I'm guessing that they used their personal email address when setting up their smart phones. 
 
Surely, this is a bug no?
1
Steve Vibert Replied
February 9, 2016 at 9:36 AM
I really would be helpful if someone from SmarterTools could at least comment on whether of not this behavior is by design or is a bug.  I really can't imagine any circumstances where I'd need or want someone's personal email address if I'm creating a SharePoint list of the contacts in the GAL.
1
Steve Vibert Replied
February 11, 2016 at 10:43 AM
Six days later and still no comments from SmarterTools--pretty disappointing.  So what next; Open a support ticket?  Seems pretty silly.
0
Employee Replied
February 11, 2016 at 12:48 PM
Employee Post
It should sync the domain email address as well as any other email addresses they list in "My Settings -> Account Profile".

I tested this and it synced correctly.  If you are not seeing the domain email address then there may be a bug.  Since I can't reproduce any issue you would need to open a support ticket for us to figure out why you are seeing different behavior.

Reply to Thread