4
Bad character encoding of messages saved via IMAP
Problem reported by Jan Angelovic - May 27, 2015 at 3:18 AM
Submitted
Hi, we have serious problem with saving messages from the Thunderbird to IMAP folders. Messages have corrupted encoding of the non-ASCII characters. But only, if “Content-Transfer-Encoding: 8bit” is used. With “Content-Transfer-Encoding: quoted-printable” everything works well.
 
Unfortunately, the first way is default in the Thunderbird. This isn’t problem with bad settings during viewing of the messages, but really with saving/transporting to IMAP folders. If same message is saved locally in the Thunderbird, it looks fine.
 
I set “mail.strictly_mime“ to the TRUE value in the Thunderbird, but is only temporary workaround.
 
This behaviour started with version 13.4.5598, definitely.
 
I will be grateful for any help.
 
 
Jan Angelovič
 
SM 13.4.5603, TB 31.7.0
 
Some pictures for illustration:
 
http://www.angelovic.cz/mail-view.png
http://www.angelovic.cz/source.png
http://www.angelovic.cz/source-hex.png

Reply to Thread