1
[SOLVED] URGENT: Could not load file or assembly 'SmarterMail.Common, Version=12.5.5409.18346,
Question asked by Sanidin Muratbegovic - May 22, 2015 at 1:11 AM
Answered
I have upgraded smarter mail to version v13 and found out that our integration don't work on v13. I have uninstaled v13 and installed v12.5, same version that was before upgrade. But now I am getting this error when I access mail folders, page /Main/frmMessages.aspx
 
Could not load file or assembly 'SmarterMail.Common, Version=12.5.5409.18346, Culture=neutral, PublicKeyToken=c39d3348656e516c' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
 
anyone know where is problem ?

2 Replies

Reply to Thread
0
Bruce Barnes Replied
May 22, 2015 at 3:53 AM
Sounds like you had locked files when you did your downgrade.
 
Do this:
 
UNINSTALL your current version of SmarterMail - all settings and data will be preserved.
 
REBOOT
 
REINSTALL your version of SmarterMail
 
Remember:  whenever you change major version numbers, you MUST UNINSTALL THE CURRENT VERSION, REBOOT and then install the newest version.
Bruce Barnes
ChicagoNetTech Inc

Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
Bruce Barnes Replied
May 22, 2015 at 4:32 AM
Glad that worked for you.
Bruce Barnes
ChicagoNetTech Inc

Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting

Reply to Thread