1
autodiscover issue
Question asked by digital.iway - March 20, 2015 at 11:55 AM
Unanswered
I am using outlook 365 to test my autodiscover setup and I am running into two issues.  I would like to know how anybody set this up to overcome these issues.
 
 
Issue 1: after autodiscover completes and account is created the outgoing port for the IMAP account is 25 and I need it to be 587.  How can I do that so autodiscover picks up 587?
 
Issue 2: looking at the created account I see that the incoming and outgoing server is now autodiscover.domain.com.  Now I know it will connect but I do not want this.  I need imap.domain.com or mail.domain.com or smtp.domain.com to populate appropriately
 
issue 3: I have a certificate on the server but still the the account gets setup without tls and the appropriate ports.
 
I have reviewed this KB but removing the a record for autodiscover does not answer the question for having it populate imap.domain.com or mail.domain.com or smtp.domain.com
http://portal.smartertools.com/kb/a2905/outlook-returning-autodiscover_domain_com-instead-information-specified-srv-records.aspx
 
 
 
 
I have a windows 2008 64bit server
 
 
has anyone done an implementation they would like to share so I can get the best setup for all devices in DNS and IIS?
 
 

2 Replies

Reply to Thread
0
Scarab Replied
March 20, 2015 at 12:16 PM
For all issues these are defined in your SETTINGS > PROTOCOL SETTINGS under "Autodiscover Host" and "Autodiscover Port". You would want your Autodiscover Host to be the same as your primary FQDN of your Mail Server (the same as your "Hostname" in SETTINGS > GENERAL SETTINGS)...normally this wouldn't be autodiscover.domain.tld unless that is the Hostname of your Mail Server. If you want your Autodiscovery to report Port 587 for all SMTP In then you would set that in your Autodiscover Port for SMTP In.
 
If you want it to use TLS/SSL then you would select the "SSL" checkbox for each protocol. If you are wanting the session to use TLS instead of SSL then you would assign your TLS Ports in the "Autodiscover Port" for each protocol.
 
 
0
digital.iway Replied
March 21, 2015 at 9:33 AM
I appreciate the info and I did some fine-tuning as you stated under SETTINGS > PROTOCOL SETTINGS
 
for POP I have autodiscover host:  pop.domain.net
 
for IMAP I have autodiscover host:  imap.domain.net
 
for SMTP IN I have autodiscover host:  smtp.domain.net (port 587)
 
under SETTINGS > GENERAL SETTINGS host name is : mail.domain.net
 
 
after doing the adjustments I setup an account and it all worked great the way I wanted it except the incoming server set itself as: autodiscover.domain.net and I need it to be imap.domain.net or mail.domain.net
 
any suggestions?
 
 
 
 
 
 
 

Reply to Thread