1
Issue getting TLS 1.2 working for POP in Smartermail 15.x
Problem reported by Nathalie V - March 2 at 1:06 PM
Not A Problem
Smartermail version: 15.4
 
 
I'm not sure what we're doing wrong, but POP is still allowing non-TLS connections even though we've configured Smartermail to ONLY use TLS for POP.
 
(SMTP works on TLS)
 
These are the current settings:
 
 
settings
 
(and each is configured to use a local certificate file and passes the certificate test)
 
 
There are 2 issues:
 
1) when I test via telnet to port 110, and enter "USER <username>" after it connects, it says "+OK User 'test' ok"  (it should disconnect at this point if it was only accepting TLS connections but it's accepting this)
 
 
2) the client connection in Outlook:  First of all I don't see a setting for POP for "tls" in Outlook, the checkbox says "ssl" (This server requires an encrypted connection(SSL).
 
I can only connect if I do NOT check the ssl box.
 
This also means it is accepting non-TLS (or non-SSL), and it should not be.
 
 
adv
 
 
Are there other settings somewhere else we're missing? I'm only aware of the settings in IP ADDRESSES and PORTS in Smartermail.
 
I have restarted Smartermail after making each change.
 
Please advise.
 

1 Reply

Reply to Thread
0
Rod Lasky Replied
March 3 at 8:19 AM
Employee Post
Hi Nathalie.  Enabling TLS for POP does not disable plain text authentication.  So this would be expected behavior.
Rod Lasky
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread