3
SmarterMail web interface will not open some attachments after patch tuesday
Problem reported by Dave Lerner - September 7, 2016 at 12:19 PM
Submitted
And now from the patch-tuesday-fixes-break-stuff department...
 
On 2 September, I applied the following patches to the the server running our SM installation:
KB3173426
KB3178034
KB3177725
KB3177108
KB3175887
KB3175443
KB3172615
 
Users are reporting issues with, of all things, plain text files. Everything works fine if you use a mail client...the attachments pass no problem. However, if you view the mailbox with the web interface, and click on the text attachment, which is shown, you get a message saying the server connection closed. If you attempt to simply right-click the text file, and select save-as, it saves a blank, empty file. The "Download All Attachments" link, which creates a zip file containing the attachment(s), however, works fine...except that you have download and unzip, etc, which users will never figure out. Pictures...
Attachment
ConnectionClosed
 
I can report the issue happens on several browsers, firefox, chrome, and IE. The attachment is not being stripped…since I demonstrated it comes through in an email client just fine. Its only when its viewed in the web interface.
 
Everything was working fine prior to these patches...you could click the text file and it would view in the browser, and you could download it as well.
 
***Update: even picture attachments, jpg, etc, cause the same problem.
 
More information:
Windows Server 20012 R2
SmarterMail Enterprise ver 15.2.6039
 
I know, I know, uninstall all the patches and try again...but I want to see if SM support can report a *specific* patch to remove, rather than just wholesale remove all of them.

1 Reply

Reply to Thread
1
Paul Blank Replied
September 9, 2016 at 9:39 AM
Any follow-up on this?

Reply to Thread