3
Upgraded from version 13.2 to 15 Parser Error Message
Problem reported by T Lewis - April 23, 2016 at 11:26 AM
Submitted
We upgraded from version 13.2 to version 15 because some of our clients were starting to have their Outlook 2013 crash when it would use activesync to sync their calendar.
 
We created a backup, stopped IIS7, uninstalled Smartermail, ran version 15 installer, started IIS7 made sure NET version of the Application Pool to .NET 4.0, restarted IIS7.
 
We are getting the following error when you try and use the Smartermail interface.

Server Error in '/' Application.
Parser Error
  Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.
 Parser Error Message: Unknown server tag 'STWC:GlobalizedLabel'.
Source Error:
 
Line 17: <asp:Content ID="Content1" ContentPlaceHolderID="MPH" runat="server">
Line 18:     <h2>
Line 19:         <STWC:GlobalizedLabel ResourceIDGlobal="@EmailAddress" runat="server" />
Line 20:         <small>
Line 21:             <STWC:GlobalizedLabel ResourceIDPage="Example" runat="server" /></small>
 
 Source File:  /Login.aspx    Line:  19

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.34280
 

8 Replies

Reply to Thread
0
T Lewis Replied
April 23, 2016 at 6:12 PM
I have tried uninstalled, rebooting and installed, but same error.
0
T Lewis Replied
April 24, 2016 at 8:03 AM
I have opened a support ticket.
 
Here are the steps I took to upgrade:
 
  1. Back SmarterMail.
  2. Stoped IIS.
  3. Uninstalled Smartermail
  4. Ran the SmarterMail version 15 installer.
  5. Installed to the same path used in previous installs.
  6. Checked to make sure .NET version of the Application Pool to .NET 4.0
  7. Setup Finished
Have rebooted, re-installed, uninstalled and installed again.
 
0
T Lewis Replied
April 25, 2016 at 8:58 AM
Started migrating the users off the Smartermail server to one of out Exchange servers.
 
Problem solved, Outlook works great, the Exchange features work great
 
All is good, have requested to close the support ticket as well.
1
Andrea Rogers Replied
April 25, 2016 at 9:40 AM
Employee Post
Hi T Lewis,

Sorry that you were having trouble with SmarterMail and that I just saw this thread now. In your first post, you mentioned that you "made sure NET version of the Application Pool to .NET 4.0." This may actually be what's causing your errors... Versions 14.x and 15.x require the .NET 4.5 framework. You can review this, and all of the System Requirements, here:  http://help.smartertools.com/SmarterMail/v15/Topics/Installation/Requirements.aspx.
 
Will you please give your upgrade a go with this new information? While I'm not terribly technical and can't guarantee your error is related, I know that not using the correct framework would cause the installation to fail. 
 
I hope this helps! 
Andrea Rogers
Communications Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
Bruce Barnes Replied
April 25, 2016 at 1:09 PM
You will need to download. NET 4.5 from Microsoft's site, install, reboot, and the ,possibility, uninstall and reinstall the most recent version of SmarterMail, released a gew days ago. .nET 4.5 is not part of the SmarterMail installation process. Nothing will need to be changed in the IIS settings.
Bruce Barnes
ChicagoNetTech Inc

Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
1
T Lewis Replied
April 25, 2016 at 1:49 PM
Yep! already know that.
Already had all the system requirements installed including .NET 4.5
The error was not related to .NET 4.5 set in the application pool as mentioned the application pool, 4.5 application can still use the 4.0 application pool setting in IIS.
 
You can also reset the application pool by running:
%windir%\Microsoft.NET\Framework\v4.0xxx.xxx\aspnet_regiis.exe -ir
 
0
Paul Blank Replied
April 30, 2016 at 8:44 AM
The repeated reporting of these issues is troublesome.
 
0
Jonathan Heintzeman Replied
October 17, 2016 at 4:23 PM
I know this is an old thread but I ended up having to do two things
 
1) manually edit the web.config by adding:  
<system.web>
    <compilation debug="false" targetFramework="4.5"/>
</system.web>
 
2) Edit the advanced settings of your Application Pool
Enable 32-Bit Applications=True
 
Uninstall (stop iis first) if it is already installed (mine was) and install again fresh.

Reply to Thread