1
Mail Delivery
Problem reported by Hari Murugan - March 16, 2016 at 3:22 AM
Resolved
Dear all,
 
I am having two separate installations (East & West) of different version of Smarter mail and having issues with email delivery.
 
East - Smartermail 11 (domain.com)    
West - Smartermail 14 (domain.net)
SMTP In - relay setting is set to nobody for both the servers.
 
I am testing delivery from web mail between both the servers and both bounces the message with 550 Authentication is required for relay bounces for domain.com and domain.net  that are hosted there. However both these server can send and receive emails from others domain (Yahoo, Gmail, anydomain) without any issues.
 
However, there are no smtp (Already set to detailed) logs and only delivery logs are available when send from domain.com to domain.net and vice versa. But that is not the case if send email to any other domains.
 
Appreciate if anyone can share their expertise.
 
Update - Enabled "Append authenticated as header for outgoing messages" in Protocol Settings-> SMPT Out without any success.
 
Regards
Harry
 
 
 

1 Reply

Reply to Thread
0
Hari Murugan Replied
March 16, 2016 at 10:26 PM
Dear all,
Just wanted to share the solution in case any one else in the same situation. Managed to resolve this issue with a ticket and the solution is related to "hxxp://portal.smartertools.com/community/a2884/security-issue-local-domain-delivery-has-higher-priority-than-dns-configuration.aspx"
 
domain.com was created and disabled in the server hosting domain.net and SM is treating mails to domain.com (even though it is disabled) as a local delivery instead of delivering based on MX record. Though the newer editions of SM have a "Domain Location" setting to address this issue. 
 
IMO, it is not correct to attempt deliveries based on domain location setting when the domains are set to disabled status.
 
Regards
Harry

Reply to Thread