1
Article Folders Don't Hide from autosearch when unticked
Problem reported by Antonio King - August 19, 2015 at 7:53 PM
Resolved
Having reported this problem to Emily already, she mentioned to post it here. THere's a bug in the folder settings for a KB article where when ticked, the articles under that folder will show in automatic searches (live chats and tickets). When unticked, it's not supposed to show them, however, it still is, regardless of that option being ticked or not.
 
My goal is to hide unnecessary folders from searches, however, with the bug, it's still showing folders/articles as results when I don't want them to. 

3 Replies

Reply to Thread
0
Antonio King Replied
August 26, 2015 at 9:46 AM
Is this bug being recognized? 
0
Employee Replied
September 8, 2015 at 3:02 PM
Employee Post
Hi Antonio,
I tested this on the latest version of 11x and was unable to replicate this issue. Here is how i attempted:
1.Created a new folder under my root folder
2. Set the new folders setting for 'Include articles in automatic searches' to unchecked
3. Made sure kb search was enabled for live chats
4. waited for the kb article to get indexed
4. went to portal and started a live chat with myself ('typing in some key words to trigger the kb article to show')
6. it did not show my kb article. 
7. i went back and turned the setting for 'Include articles in automatic searches' back to checked and started another chat with myself typing in the same key words. 
8. the article did show.
 
If i did not test this correctly give me exact steps and I will try again on my local install.
Thank you,
0
Antonio King Replied
September 9, 2015 at 5:26 AM
Thanks for the reply, Ashley. It wasn't a successful test for you because it looks like that was patched in the latest release. 
 

Version 11.2.5717 (2015-08-27)

  • Fixed: Knowledge Base option for "include articles in automatic searches" now functions properly when unchecked.

Reply to Thread