1
Iphone Smartmail Integration
Problem reported by William Gauderman - October 6, 2014 at 10:47 AM
Submitted
Hello, I am using SmarterMail 12.1 and am having issues syncing this email to the iphone.
 
It seems the two have a mind of there own. I receive some messages on the phone and some on smartermail, but niether item gets the same.
 
I had some folders created within smartermail and now my Iphone has the folders and they are removed from my smartermail.
 
My details are as follows please help. I'm loosing my mind trying different things.
 
IMAP Account
 
Outgoing SMTP Mail Server
SSL is Off
Authentication is MD5 Challenge-Response
Server port 25

Incoming Settings
SSL is off
Authentication is Password
IMAP Path Prefix (Blank)
Server Port 143 

1 Reply

Reply to Thread
0
Bruce Barnes Replied
October 6, 2014 at 11:18 AM
You indicated that you are attempting to connect your iPhone to SmarterMail 12.1 using IMAP.
 
If you are the SmarterMail server operator, then you need to upgrade to the latest version of SmarterMail as there have been several issues with IMAP which were fixed in versions subsequent to SmarterMail 12.1.  To see a list of improvements to later releases of SmarterMail see the document at: http://www.smartertools.com/smartermail/releasenotes/v12.aspx
 
The most current version of SmarterMail is 12.4.5364
 
The fixes and patches in subsequent versions of SmarterMail, since 12.1, include:
 
in 12.2.5226
  • CHANGED: IMAP commands are no longer returned in all caps.
  • CHANGED: IMAP Retrieval now sends the password in quotation marks.
in 12.2.5283
  • FIXED: The IMAP fetch query for a message's envelope now correctly handles email addresses that contain quoted user name parts such as "user name"@domain.com.
in 12.3.5308
  • FIXED: The IMAP ENVELOPE command response now correctly escapes quote characters when returning the subject value.
 
If you are not the SmarterMail server operator, then you will need to contact your provider to let them know they need to install the upgrade to help eliminated IMAP issues.
 
 
You should also consider the use of port 587 in lieu of  port 25, when setting up your account(s).  In their efforts to fight spammers, many internet transport providers block port 25 for client to MX server communications. 
 
The following ISPs, both in the USA and around the globe, are known to block all device to MX server traffic on port 25:
  • Comcast
  • Verizon
  • AT&T
  • NetZero
  • Charter
  • People PC
  • Cox
  • EarthLink
  • Verio
  • Cablevision
  • All Japanese ISPs
  • France Telecom/Orange
 
The alternate port, 587, is now mandated as a MUST BE OPEN port on all MX servers by the IETF. 
 
 
See: https://portal.chicagonettech.com/kb/a104/blocking-of-alternate-smtp-port-587-by-isps-now-prohibited.aspx for more information on the mandate by the IETF that port 587 MUST be open on MX servers.
Bruce Barnes
ChicagoNetTech Inc

Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting

Reply to Thread