1
Chat Feature - Webmail
Question asked by CCWH - March 5, 2015 at 9:24 AM
Answered
Hello all,
 
We never got round to configuring the XMPP Chat feature of our SM Enterprise installations.  However, a new client has requested if we can implement a chat feature for them.  So...I thought we might as well get the XMPP chat up and running within Webmail.
 
We are on SM Enterprise 13.2, Server 2008 R2 / 2012 R2, IIS 7.5 / 8. Mail on Own IP.
 
So far I have:
- Enabled all Domains and Users as per THIS KB
- Configured IP Binding for ports 5222 / 5269 (using TLS...unsure if that is correct?)
- Opened port 5222 on the server just in case.
 
Unfortunately the above config does not allow Chat.  I have logged in using IE as one user and Chrome as another, changed both to 'Available' then opened a chat window...however the other user within Chat states 'Offline'.....this is within Webmail.
 
Can someone spot what I am missing here?
 
Many thanks

10 Replies

Reply to Thread
0
CCWH Replied
March 5, 2015 at 10:34 AM
Thanks Joe.
 
I am a little further ahead now, well, when using an XMPP client (Pidgin).  It does connect over TLS galdly using the XMPP client.  However, it all doesn't make sense.  Firstly, the webmail interface still shows all users offline no matter how I configure the XMPP within admin.  I have made sure all domains/users have XMPP enabled (through propagation and manually just in case).
 
This is the weird thing.....
 
It just so happens that the email server I am testing on also hosts a test website on it's own dedicated IP which also has test email accounts which I am using for the XMPP testing.  To get XMPP to work (only by using Pidgin) I had to go into IP Addresses on the email server and bind XMPP on the dedicated IP address for the test website.  As soon as I did that Pidgin connected.
 
Now, thinking about it...it makes sense...ish!  I have a test email address of test@testdomain.com.  When I configure Pidgin (as per this KB) I have to split the username (test) and the domain (testdomain.com).  What actually happens is the connection on port 5222 goes out to testdomain.com.  So, by enabling XMPP on that domains dedicated IP it connected.  All sounds good....until the realisation that IF the chat feature relies on the FQDN IP address residing on the email server...which in all cases when using a dedicated email server wouldn't happen.
 
Am I making any sense?!  It all seems very strange indeed!
0
CCWH Replied
March 6, 2015 at 10:31 AM
Thanks for the input Joe.
 
We have got the chat feature working with a few different XMPP Chat Clients...all using TLS and no plain text authentication so that's all great news.  However, we still cannot chat within webmail.  Very weird indeed.  The two test users both have the 'available' shown to the top right which isn't there when the user/domain does not have Chat enabled.
 
We are testing from the same PC but using different browsers...would that cause an issue?  I think I will jump onto another PC just in case and test but can't see that being the problem.
0
CCWH Replied
March 7, 2015 at 3:12 AM
I really am tearing my hair out with this one. It seems as though all configuration is correct but still not Webmail chat. All users are set to Available but none show up as online to others within Webmail.... But using a number of different XMPP clients it works flawlessly
0
Merle Wait Replied
May 13, 2015 at 12:34 PM
Did you ever get the above resolved?
We are getting to where the WebChat interface is too unreliable to use.
 
What happens is similar to what you are describing.
What happens is:
a.) Person A - logs on.. make themselves available.
b.) Person B - logs on.. makes themselves available as well.
c.) Person C  - does the same....
at some point person a or b or c.. can have a chat with the others. no problem.
 
BUT,  person A, somehow no longer shows themselves to be available.. from Person B or Person C perspective.
"A"  - thinks they are available, because they still show green AVAILABLE...  
so now person B and C can't chat with person A... and Person A doesn't understand why no one is communicating.
 
This happens everyday....
I have looked in logs, but don't see anything too revealing.
 
0
Bernd Replied
May 17, 2015 at 5:07 AM
Hi CCWH.
 
I think, you are missing this:
 
Login as admin, click settings, click protocol settings, click the XMPP tab.
Change the URL Listener from:
 
+:80/http-bind/
 
to
 
your.server.com:9998/http-bind/
 
Assumed you are using port 9998, the built-in Chat client should work after saving.
1
Bruce Barnes Replied
May 17, 2015 at 5:23 AM
SmarterMail uses the XMPP standard as the basis for their built-in chat client.
 
Per the standards published by XMPP.ORG [https://xmpp.org/extensions/xep-0035.html], the following ports are the standard ports to be used with XMPP chat.
 
2. Protocol
2.1 Overview

This protocol operates over the standard Jabber client connection on port 5222.

The namespace identifier for this protocol is https://www.ietf.org/rfc/rfc2595.txt.

By default, the XMPP module Listener accepts clear text connections on:
 
  • TCP port 5222 ("client port") 
  • TCP port 5269 ("server port")
  • Some servers have also designated TCP port 5223 for secure TLS connections ("secure client port").
The ports listed above are configured under SETTINGS ===> BINDINGS ===> PORTS
 
XMPP Port Configurations in SmarterMail
XMPP Port Configurations in SmarterMail
 
and must also be bound to the IP ADDRESS on which your SmarterMail server is operating:
 
Port to IP ADDRESS Bindings in SmarterMail
Port to IP ADDRESS Bindings in SmarterMail
 
Once you have bound the ports to the IP address, you must also map the IP ADDRESS to a FULLY QUALIFIED HOSTNAME on the hostname's PUBLIC IP address:
 
IP to HOSTNAME mapping
IP to HOSTNAME mapping
 
 
 
 
The webchat ports, which are set as part of the SETTINGS ===> PROTOCOL SETTINGS ===> XMPP are standardized as:
http://+:9998/http-bind/ can be used where port 9998 is being used.
 
XMPP HTTP Protocol Bindings for Web Chat
XMPP HTTP Protocol Bindings for Web Chat
 
NOTES:
  • TLS will not work unless IIS is being used, and that means both ENABLING IIS and DISABLING the internal SmarterTools webserver.
  • All ports must be opened on all firewalls
Bruce Barnes
ChicagoNetTech Inc

Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
Merle Wait Replied
May 17, 2015 at 5:41 AM
SM folks.. answered my issue:
 
Refer to:
1
CCWH Replied
May 18, 2015 at 1:08 PM
Bruce - Genius!  Thanks for your help.
 
We had everything configured correctly apart from the IP to HOSTNAME...we didn't have that mapped.  As soon as I have added that the Web Chat has sprung to life!  Very weird as I haven't seen that mentioned for Web Chat anywhere else!
 
Thanks again :-)
0
Bruce Barnes Replied
May 18, 2015 at 1:22 PM
Glad that helped, CCWH!
Bruce Barnes
ChicagoNetTech Inc

Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
dean brown Replied
April 11 at 7:45 PM
Re: IP to HOSTNAME mapping
What are the ramifications of adding this? (SM 15 Ent, 100 hosted domains, 1 IP address)
 
We currently have no entry in here...
Thanks! First time setting up XMPP support

Reply to Thread