1
smartermail cannot retrieve emails on windows 2012r2 through ssl
Problem reported by Stefan - February 27, 2015 at 2:30 PM
Submitted
Hi,
I am migrating my mailserver from windows server 2003 to 2012r2 and am experiencing some problems. The first was solved in: hxxp://portal.smartertools.com/Main/frmThread.aspx?threadid=2068, but now I am stuck in the next stage:
Smartermail does not retrieve any emails from external mailboxes. My external mail accounts only support ssl encryption. When I press "Test connection" in the message retrieval menu everything looks good ("The message retrieval connection was successful.") but when I press "Retrieve" nothing happens (no mails are downloaded, no entry in any logfile). I enabled ssl and tls on the server with IISCrypto (used: "best practice" button). With wireshark I can not see any traffic going out of the server on port 995...
Does anybody use smartermail on 2012r2 with message retrieve on ssl?
Best regards,
Stefan
 

3 Replies

Reply to Thread
0
Stefan Replied
March 1, 2015 at 5:43 AM
it's getting stranger...
I did a clean smartermail install on a freshly installed 2012r2. Result: pop retrieval is working... (as expected...) I see corresponding messages in the popRetrieval Logfile (I could not see those messages in the logfile of the other server, only "pop retrieval server startet/stopped"!).
Now here comes the big question: Why is it not working on the other system? Are there any Windows settings that prevent smartermail from retrieving emails? What can I do to find the misconfiguration?
I am not in the mood to re-setup my second DC on which smartermail should run...
Any Ideas?
Regards,
Stefan
0
CCWH Replied
March 1, 2015 at 6:25 AM
SM doesn't have any special requirements for a 2012 R2 installation.  Ours was only installed recently without any issues.
 
So, normal setup, IIS (inc port 9998 if not dedi), Firewall (open normal 110/143/587/9998 etc.), install/configure certificate, export cert and import into SM.  Configure TLS ports.  Bind to Mail IP.  Nothing new really.
 
Might be worth checking or rerunning IISCrypto...remember you need to reboot the server for the full changes to take effect.
 
Check your SM Services too - http(s)://YourMailIP/Services or login to SM admin > Settings > Advanced Settings > Web Services
0
Stefan Replied
March 1, 2015 at 8:15 AM
Thanks for the answers.
It seems like SM is working now. I deleted  and re-created one of the "message retrieval" accounts per user and now all messages are retrieved from all accounts.
I have no idea why that healed the system, but obviously it did...
Best regards
Stefan

Reply to Thread